Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Failed on make test' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Failed on make test
Authored by: ilovja on Nov 04, '03 04:34:18AM
I had suffered from the same problem. Probably, you have seen something like the following message at the end of your installation try.
Running make install... make test had returned bad status, won't install without force
You can ignore minor failures which occured during the test and install with force using manual installation. Get DBD::mysql module from CPAN. extract it to the temp directory.

perl Makefile.PL
perl -pi -e 's/MACOSX/env MACOSX/' Makefile
make test
make install
My purpose of getting DBD::mysql was running MovableType. After I installed DBD::mysql with force, I tested posting/rebuilding using all the MT-related data restored from my backup. And it worked. However, it was a basic test. I might run into another problem from now on. Try this at your own risk.

[ Reply to This | # ]
Thanks--it works!
Authored by: lemur on Nov 13, '03 01:30:12PM

After slogging at this for two days with latest version of Perl on a fresh from scratch install of Panther + dev tools, I found this thread.
The env hack to Config.pm and the advice about the force install for DBD:mysql worked for me. Haven't tested extensively, but perl and mysql are now on speaking terms.



[ Reply to This | # ]
No Luck
Authored by: HappyTheMan on Sep 23, '04 10:38:18AM

I'm using Mac OS X 10.3.5. I have made the modification to the Config.pm file (ie, adding 'env'). But when attempting to install DBI for Moveable Type 3.11 - I still get the error telling me that /System/Library/Perl/5.8.1/darwin-thread-multi-2level/CORE/perl.h canot be found. I looked - it isn't there.

When i tried to force the install as per the instructions above - still nothing.

This is a LOT of effort to install Moveable Type. Too much. It looks like a Great blog server.... BUT I'LL NEVER KNOW!

I've read that Apple is including a blog server, based on Blojsom, in Tiger Server (Mac OS X 10.4). Thats still eight months (or more) away.

I looked into installing Blojsom and it was sufficiently complex that I checked out Movable Type. My experience trying to install Movable Type is driving me to find another blog server. Wordpress looks nice; maybe I'll try that now.

I'm despairing of ever making a blog-based site work. PostNuke and similar CMS solutions are easy to install and configure, in my experience. Why the #%&$ are these blog solutions so difficult?

Peter

---

--
Peter Norman
St. John's, Newfoundland, Canada

"Anyone who has never experienced the bitterness of despair
has missed life's significance." Soren K



[ Reply to This | # ]
No Luck
Authored by: PeteVerdon on Sep 23, '04 05:52:42PM

It's not a lot of effort to install Moveable Type, it's a lot of effort to install a Perl module. Any system, weblog or CMS, that needs that module will be equally hard to install. (Postnuke, of course, uses PHP rather than Perl so this doesn't apply, but that's not because it's a CMS system rather than a weblog one.)



[ Reply to This | # ]