Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'another error' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
another error
Authored by: hap on Sep 04, '03 02:40:36AM

It fails when I run it with the following error

Exception in thread "main" java.lang.NoClassDefFoundError: Resources/JBuilder/icns

this can be explained by the fact that this directory does not exist any ideas on how to fix this.



[ Reply to This | # ]
another error
Authored by: aquaman on Sep 04, '03 11:48:37AM

On the exec line when you are actually calling Java, don't put a space after "JBuilder.app/Contents/\". Or just put that whole section on a single line (the backslashes as the end of a line just tell the shell to continue to the next line).



[ Reply to This | # ]
another error
Authored by: hap on Sep 04, '03 04:28:29PM

Thanks I miised that. it's launching finer now.



[ Reply to This | # ]
another error
Authored by: Sandero on Sep 04, '03 09:06:53PM
hi =) so, my situation is:

exec /System/Library/Frameworks/JavaVM.framework/Versions/$jdk/Commands/java \
-Xdock:name="JBuilder 8_Ent":icon=$JBUILDER_HOME/JBuilder.app/Contents/\Resources/JBuilder.icns \
-Xmaxf0.2 \
-Xminf0.2 \
-Dapple.laf.useScreenMenuBar=true \
-Dapple.awt.showGrowBox=$useGrowBox \
-Xverify:none \
-Xbootclasspath/p:../lib/lawt.jar:../lib/javac.jar:../lib/TabbedPaneFix.jar:../lib/SequencedEventFix.jar:../lib/JarManifestFix.jar:\/System/Library/Java/Extensions/MRJToolkit.jar \
-Xms32m \
-Xmx256m \
-cp ${jars}:/System/Library/Java \
com.borland.jbuilder.JBuilder $args

and the error that i have after duble click:

% /Users/UserName/JB9alt.command; exit
Environment
PWD=/Users/UserName
VENDOR=apple
PERL5LIB=/sw/lib/perl5
TERM_PROGRAM=Apple_Terminal
MANPATH=/sw/share/man:/sw/man:/usr/local/share/man:/usr/local/man:/usr/share/man:/usr/X11R6/man
USER=username
MACHTYPE=powerpc
TERMCAP=???
LANG=it_IT
HOST=UserName.local.
INFOPATH=/sw/share/info:/sw/info:/usr/local/share/info:/usr/local/lib/info:/usr/local/info:/usr/share/info
LOGNAME=UserName
SHLVL=2
GROUP=staff
SHELL=/bin/tcsh
HOSTTYPE=macintosh
OSTYPE=darwin
HOME=/Users/UserName
TERM=vt100
TERM_PROGRAM_VERSION=81
PATH=/sw/bin:/sw/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin
__CF_USER_TEXT_ENCODING=0x1F5:0:4

_=/usr/bin/env

-info
Exception in thread "main" java.lang.NoClassDefFoundError:
logout
[Process completed]

what's wrong? i see that in the log file of installation i have this error:

Install File: /usr/local/bin/jbuilder
Status: ERROR

i've install Jb9 more times but this errors persists.. is possible that this error are associated at the problem in start?
thanks for your help and i hope that my information are clear and complete..
Sandero

[ Reply to This | # ]
another error
Authored by: hap on Sep 05, '03 03:22:37PM

This looks similar to my error. Make sure to follow aquaman's advice and make sure you don't have any rouge spaces gumming up the works. Make sure you check both after the / and on the begining of the next line.



[ Reply to This | # ]
another error
Authored by: Sandero on Sep 06, '03 06:55:15AM

Great! it's running now =)
thanks a lot! The problem was situated in a space situated after the / in an end line! (i've read this from another your message in another post!)
Thank you very much for your help!
bye!

--
Sandero



[ Reply to This | # ]