Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Lock database? What Lock database?' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Lock database? What Lock database?
Authored by: elmlish on Jul 28, '03 03:40:13PM


Hello, i followed the steps from the parent post, put together this directory in httpd.conf..

<Directory "/Users/elmlish/Sites/dav"\>
DAV On
AuthName "dav"
AuthType Basic
AuthUserFile /Users/elmlish/Sites/dav/.htpasswd
<LimitExcept GET HEAD OPTIONS PROPFIND>
require valid-user
</LimitExcept>
</Directory>

and end up getting this Error when I browse to http://localhost/~elmlish/dav

Error: A lock database was not specified with the DAVLockDB directive. One must be specified to use the locking functionality. [500, #401]

Where do I specify a DAVLockDB database? In the directory, or closer to the LoadModule stuff?

btw.. I'm using Complete Apache 2.47 with Complete PHP 4 on Mac os X 10.26.



[ Reply to This | # ]
Lock database? What Lock database?
Authored by: elmlish on Jul 28, '03 04:17:32PM

I've mucked around using the the step through here:
http://www.webweaving.org/ical/
and I've got something closer to working.


These were the steps I missed in getting a Lock Database:
"""
create the empty lock databases and make sure that they are owned and writable by the web server:

touch /var/db/DAVLock.dir
touch /var/db/DAVLock.pag
chown www /var/db/DAVLock.*
chgrp www /var/db/DAVLock.*
chmod 640 /var/db/DAVLock.*
"""

Now I just can't seem to get authenticated.
This is the error that I get:
Digest: user `elmlish' in realm `iCal' not found: /~elmlish/dav/ical

Now I've got a password file here:
AuthDigestFile "/Library/Apache2/etc/dav.digest.passwd"

but from the looks of the error message, it doesn't seem to be looking there. Anyone have any ideas on what I should be doing now?



[ Reply to This | # ]
Lock database? What Lock database?
Authored by: meximilian on Jan 12, '04 11:41:15AM

hi, im using the standart apache server of 10.3.
is the dav module included in this version ... can anyone give me a working http.conf? i think im too stupid to edit this file the right way ... thx in advance ... mexx

---
greetingz mexx



[ Reply to This | # ]