Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Discovering Correct Device URL solution' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Discovering Correct Device URL solution
Authored by: gsamsa on Mar 28, '03 01:34:07PM

As mentioned in another reply here, I too had a bit of trouble getting this to work due to a difference in the sequence of steps after step 8- i.e. after step 8 i was prompted for a device url location. I tried a number of different approaches outlined in replies here, but nothing seemed to work, and I couldn't figure out how to get the specific correct usb:// device url I should enter. Finally in another thread i stumbled across the solution, and thought i would post it here to save anyone else in my predicament a little time and trouble. So to determine the correct device url:

1. Open the Print Center in the /Applications/Utilities/ folder.
2. Select the printer from the list (in my case the STYLUS C80)
3. Hold down the Option/Alt key and click the Add button
4. Select the "Advanced" option from the drop down menu
5. Then select the STYLUS C80 printer from the "Device" menu 6. This results in the device URI being displayed in the field in the format outlined in the directions above.

After discovering that, set up was easy following the procedure outlined above and printing from my wife's Win2K box works great.



[ Reply to This | # ]
Discovering Correct Device URL solution
Authored by: mgalke on Jan 22, '04 04:36:35PM

I followed all your instructions to the letter (great post by the way) but unfortunately, it doesn't work for my printer, an HP Photosmart 7550, which is disconcerting because it's a relatively new printer on their (HP) product line. Basically, the job makes it from the Win box to the print queue on the iMac, but then it just sites there and says, "GenericClass - Waiting for Device". A few things I've done already:

1) I got to step 11 in your post, but my "model/driver" doesn't show up in the list.
2) I then tried to use "raw" and "raw-queue" as suggested in one of the replies to your post. No joy.
3) I downloaded and installed the Gimp Print drivers for my HP (actually, even Gimp doesnt' make a Gimp compatible driver for my Photosmart 7550, but on Sourceforge.net's site, they have a driver compatilbility chart, and I selected those drivers instead (HP Deskjet 550c drivers, also HP Deskjet 900 Series drivers). Still no joy.

No matter what I do, the job DOES go to the queue on the Mac that has printer sharing enabled, but that's all... it just sits there w/ that message of "GenericClass -Waiting for Device".
Any ideas Bro??? This is really driving me crazy, and I've used up all of my resources. I'm completely stumpted!!

Thanks, Mike

Environment:
Mac = iMac flat panel 800 w/ 768 MB ram, with Printer Sharing enabled. HP Photosmart 7550 is patched into this Mac via USB, directly into ISB port.

Windows box = Acer Laptop / 16 GHz, 260 MB ram. This machine is brand new.

---
Thanks,
Mike



[ Reply to This | # ]