Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Running JBuilder after Java 1.4.1 breaks it' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Running JBuilder after Java 1.4.1 breaks it
Authored by: ravedog on Mar 13, '03 02:42:29PM
from the MacFixIt site:

Fix for JBuilder 7 We previously reported that ince Java 1.4.1 has been installed, JBuilder 7 stops working. Apple has now posted a developer note offering a solution:

  1. In your JBuilder7 folder, navigate to JBuilder.framework/bin/
  2. Open the jdk.config file in a text editor. You may need to do this from the shell with the sudo command depending on how the permissions to JBuilder7 are set. For example, type sudo vi jdk.config
  3. Add the following line: javapath /System/Library/Frameworks/JavaVM.framework/Versions/1.4.1/Libraries/libjvm_compat.dylib.
  4. Save the file and launch JBuilder7 by double clicking the icon.


[ Reply to This | # ]
Running JBuilder after Java 1.4.1 breaks it
Authored by: craig on Mar 13, '03 04:39:26PM

I tried that, but JBuilder is still using Java 1.3.1 (you can tell by choosing About JBuilder, then clicking on the Info tab). The only way to get it use 1.4.1 is from the command line.



[ Reply to This | # ]
Running JBuilder after Java 1.4.1 breaks it
Authored by: stevechamp on Mar 23, '03 03:50:40PM

This worked for me!

Thanks much,
Steve C.



[ Reply to This | # ]