Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Cannot boot of CD ROM' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Cannot boot of CD ROM
Authored by: geoffsaulnier on Dec 21, '00 07:59:21AM

I had this - could not boot off OS 9 CD ROM, could not boot OS X or OS 9, and could not
reinstall X from OS X CD ROM!!!!

For the record, I got the error: "Code fragment could not be completed" from the OS 9 boot
sequence which I have never, ever seen before in 13 years of Mac use!! Woohoo!

Here's my fix:

Put your OS 9 CD in. startup and zap the P-RAM (or NVRAM) with option-command-P-R on
startup. Zap it a couple of times and then, when it is restarting, hold down C and it should
boot from the CD ROM. If not, try another few zaps and hold down C. IF you try to boot into
OS 9, it will fail, and then the CD ROM boot will also fail. The CD ROM boot attempt must
come directly after zapping the NVRAM.

Once in the OS 9 CD, I backep up and reformatted all my drives, but I'm pretty sure a clean
install of the system would fix the problems for OS 9. I'm also pretty sure that re-installing
OS X will fail (it did for me) so tar up and pull off /Users and /Applications to somewhere
else, reformat, reinstall X and overlay the Applications dirs. You'll have to recreate all the
users, but then you can overly /Users (although I didn't - I only overlaid /Users/username/*

Also, my Entrega USB card no longer works under OS 9 despite reinstalling the drivers - but
it works under OS X!!!

Cheers,
Geoff Saulnier - Mac, *NIX, perl - hack!!!



[ Reply to This | # ]
Cannot boot of CD ROM
Authored by: Anonymous on Dec 24, '00 12:50:12PM

I had the same problem a couple days ago...
I installed a new and bigger hard disk in my [original] iBook. I did a full install of Mac OS
9.0.4 on the first partition and only had a problem with "Automatic Update Software" crashing
my machine. I fixed that problem and then installed Mac OS X PB and dev tools.
Everything worked OK but I couldn't reboot in Mac OS 9. I tried from a CD and it didn't work.
After a while my iBook refused to boot from the CD or HD.

I zapped the PRAM (NVRAM) about ten times with the CD installed in the iBook [rebooted
with "C" pressed] and it did the trick.

I ran Disk First Aid 8.6 and it reported that both of my partitions had "wrappers" errors
[described on macfixit.com and macintouch.com pages].

After the partitions were repaired I had no problem switching back and forth between Mac OS
9 and Mac OS X PB.

Hope this gives some help...

alpinus



[ Reply to This | # ]
PB G3/250 - OS9 Boot Problems
Authored by: Anonymous on Mar 31, '01 03:15:10PM

I'm having the same issue on my Powerbook G3/250. I found that the OS9.1 CD would boot only after the machine had been turned off completely, and then turned on with "c" key down.

In any event, no amount of reinstalling (either X or 9.1) has fixed the problem. I believe the issue may have stemmed from installing X onto the same partition as 9.1.

While it should be irrelevant, I did have Yellow Dog Linux installed prior to X (but the drive was wiped before the X install).

I'm planning on formatting the drive again, but this time installing the OSes on different partitions.



[ Reply to This | # ]
Update
Authored by: Anonymous on Apr 01, '01 05:51:42PM

I just formatted (zeroing out the data) my drive and reinstalled both OSX and OS9.1 (on seperate partitions this time). On my first boot, I got the blinking question mark after I had installed 9.1. After I zapped the pram a few times it booted. Now it appears that both system's work fine. We'll see.



[ Reply to This | # ]