Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Failed with HP LaserJet 1200' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Failed with HP LaserJet 1200
Authored by: marick on Dec 14, '02 02:30:54PM

I've failed with this on Jaguar connected to an HP LaserJet 1200 by
USB. My wife's machine is stock Win2K.

When I print from the Win2K box, the output looks like uninterpreted
PCL:

<gibberish>
@PJL COMMENT "..."
@PJL SET RET=ON
<ad infinitum>

This happens both when I set the printer up as in the original
instructions and also when I use "raw".

Perhaps worth noting:

- The same thing happens when I print from the Mac to the new printer
definition. (It continues to work when I print to the original.) In
this case, the gibberish looks different. (CUPS describes the
original printer as a "generic postscript printer", so it's
presumably postscript-ish gibberish.)

- When I click on the print test page for the new printer definition,
the page is sent, but nothing happens. When I look at the completed
jobs, I see: "cancelled at <date/time>". (The gibberish jobs show
as completed.)



[ Reply to This | # ]
Failed with HP LaserJet 1200
Authored by: marick on Dec 14, '02 04:36:52PM

Note: I installed the LaserJet 1200 PPD file. Didn't change anything when printing from the Mac: I still get gibberish. Now when I print from Win2K, nothing appears. The job is listed as cancelled in the CUPS admin page.



[ Reply to This | # ]
Failed with HP LaserJet 1200-a fix
Authored by: vlhvst on Jan 01, '03 04:00:05AM

The following worked for me.
1. Configure the second copy of HP LaserJet 1200 on mac as a generic postscript printer.
2. Create a network printer on win** (win98 in my case) and configure it as Apple LaserWriter II NT



[ Reply to This | # ]
Failed with HP LaserJet 1200-a fix
Authored by: chrispar on Oct 31, '03 09:40:47AM

This worked for me as well except I found I didn't need to create a second LaserJet 1200 printer driver on the Mac - the normal OS X driver worked with Windows XP thinking it was printing to an Apple LaserWriter II NT.

---
--
Chris



[ Reply to This | # ]
Failed with HP LaserJet 1200
Authored by: mgalke on Jan 22, '04 04:34:46PM

Hey Hoosier,
I followed all your instructions to the letter (great post by the way) but unfortunately, it doesn't work for my printer, an HP Photosmart 7550, which is disconcerting because it's a relatively new printer on their (HP) product line. Basically, the job makes it from the Win box to the print queue on the iMac, but then it just sites there and says, "GenericClass - Waiting for Device". A few things I've done already:

1) I got to step 11 in your post, but my "model/driver" doesn't show up in the list.
2) I then tried to use "raw" and "raw-queue" as suggested in one of the replies to your post. No joy.
3) I downloaded and installed the Gimp Print drivers for my HP (actually, even Gimp doesnt' make a Gimp compatible driver for my Photosmart 7550, but on Sourceforge.net's site, they have a driver compatilbility chart, and I selected those drivers instead (HP Deskjet 550c drivers, also HP Deskjet 900 Series drivers). Still no joy.

No matter what I do, the job DOES go to the queue on the Mac that has printer sharing enabled, but that's all... it just sits there w/ that message of "GenericClass -Waiting for Device".
Any ideas Bro??? This is really driving me crazy, and I've used up all of my resources. I'm completely stumpted!!

Thanks, Mike

Environment:
Mac = iMac flat panel 800 w/ 768 MB ram, with Printer Sharing enabled. HP Photosmart 7550 is patched into this Mac via USB, directly into ISB port.

Windows box = Acer Laptop / 16 GHz, 260 MB ram. This machine is brand new.

---
Thanks,
Mike



[ Reply to This | # ]