Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'New Poll: The Obligatory Mountain Lion Poll ' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
New Poll: The Obligatory Mountain Lion Poll
Authored by: djcaliendo on Jul 24, '12 12:14:47PM

I don't plan on going to Lion or Mt. Lion until I have to. Doing so will obligate me to buy software no longer compatible
with Lion (e.g. Microsoft Works for Mac). Many of us are offended at the lack of support from Apple for Snow Leopard
which isn't that old.



[ Reply to This | # ]
New Poll: The Obligatory Mountain Lion Poll
Authored by: bobfly06 on Jul 24, '12 02:01:55PM

I fully agree with "dicaliendo"! I'm still using Snow Leopard mainly to be able to keep using the best program that every came to the Mac. What is it?? APPLEWORKS!!!! That program had everything for the "common" user like me. Used it for years and loved it!!!!



[ Reply to This | # ]