Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Install recent versions of Adobe Creative Suite on case-sensitive volumes' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Install recent versions of Adobe Creative Suite on case-sensitive volumes
Authored by: lokkju on Jan 24, '12 04:15:09PM

Author of the "cleaner solution" here...

I actually tried a few different clean up scripts, and tried to write my own by detecting frameworks in use... and I eventually gave up on finding all the things that needed to be fixed. The *biggest* problem I ran into was that there were a few different applications (iirc, Photoshop and Fireworks) where one app required a framework be lowercased, while the other required proper casing.

After I ran into that little issue, I decided to just do the disk mounting solution - and it works *really* damn well. The next step would be to automate it all and offer it as a binary download for those without dev tools... but that is quite a bit of effort.

I could actually easily automate offer the Installer loader as a binary, getting rid of the Developer Tools requirement... may have to do that.



[ Reply to This | # ]
Install recent versions of Adobe Creative Suite on case-sensitive volumes
Authored by: arcticmac on Jan 25, '12 07:14:57AM

The solution I came up with to that issue was symlinks... I don't understand why Adobe can't just do that work itself though. It would only take somebody a couple of hours, which is probably less time than it took them to put the stupid hooks in the installer so that it doesn't install on case sensitive disks...



[ Reply to This | # ]