Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Get SPSS working again after the latest Java release' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Get SPSS working again after the latest Java release
Authored by: myz on Oct 25, '10 12:41:08PM

Today I faced this little nasty problem too.... and all the hints above did not work for me... Finally I tried a mix of all the suggested solutions and that worked fine. First I got and extracted an old version of java 1.5.0. Then I removed the symlinks for 1.5, 1.5.0 and CurrentJDK in /System/Library/Frameworks/JavaVM.framework/Versions/. Third step: I moved the directory to /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0-leopard and created the symlinks for the "new" java library (sudo ln -s 1.5 1.5.0-leopard && ln -s 1.5.0 1.5.0-leopard && ln -s CurrentJDK 1.5.0-leopard). That it's.

And here is the short way to do it.

[code]
wget -P /Users/NAME/Downloads/ http://www.cs.washington.edu/homes/isdal/snow_leopard_workaround/java.1.5.0-leopard.tar.gz
tar -zvxf java.1.5.0-leopard.tar.gz
cd /System/Library/Framework/JavaVM.framework/Versions/
sudo rm 1.5 1.5.0 CurrentJDK
mv /Users/NAME/downloads/1.5.0 /System/Library/JavaVM.framework/Versions/1.5.0-leopard
sudo ln -s 1.5 1.5.0-leopard && ln -s 1.5.0 1.5.0-leopard && ln -s CurrentJDK 1.5.0-leopard
[/code]

Feedback is welcome. :-)



[ Reply to This | # ]