Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.5: Use 1Password 2.x in Safari 5 for Leopard' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.5: Use 1Password 2.x in Safari 5 for Leopard
Authored by: albyrw on Jun 08, '10 06:47:25PM

That's true, with certain caveats: the 1Password 2 application will run just fine in Snow Leopard, and version 3 runs in Leopard. But for Safari integration in 10.6, you have to run Safari in 32-bit mode. The Agile guys are a great bunch of guys and the most diligent of app updaters, but they made the decision not to continue to support both 32 and 64-bit versions of the browser add on - fair enough. If you go looking for an update to 1Password 2.x today to update for Safari 5 support, you won't find it.

Those of you who need this hint, e.g. those with PowerPC Macs, you know who you are. If you've paid for your license and your hardware or some other reason precludes you from upgrading, I don't think Agile are going to begrudge you altering a file so you can continue to use Apple's latest browser.

Note that syncing still works between 1Pwd 2.x and 1Pwd 3.x if you use the Agile keychain.



[ Reply to This | # ]