Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.6: Make some open source screen savers work in 10.6' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.6: Make some open source screen savers work in 10.6
Authored by: jwz on Jan 14, '10 02:31:16PM

What in the world are you talking about? The MacOS builds of XScreenSaver have been 3-way compiled for ppc, x86 and x86_64 since xscreensaver version 5.09 released back in September. The same executables will install and run without modification on any Mac (ppc or intel) running MacOS 10.4.0 through 10.6.2.

Incidentally, getting these to work on 10.6 was not simply a matter of recompiling them. The 10.6 version of ScreenSaverEngine did not only require that things be compiled for x86_64 -- it also required that garbage collection be turned on, and that resulted in a bunch of unexpectedly complicated memory-corruption bugs.



[ Reply to This | # ]
10.6: Make some open source screen savers work in 10.6
Authored by: asmeurer on Jan 14, '10 08:26:03PM

Yep. You are right. I have to apologize on this one. I didn't notice that the source had already been updated for 10.6 until after I submitted this.

I did notice that some screensavers (ant I believe was one of them, a really neat one) were not in the binary download but did build from the source. Or maybe I just missed it.

Thanks you for you hard work on this.



[ Reply to This | # ]