Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Install and configure Tripwire from source' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Install and configure Tripwire from source
Authored by: JPry on Jan 12, '10 10:11:09AM
I'm running 10.6.2, and everything seemed to be working fine until I tried the "sudo make install" command. It will probably work on 10.6, but with some modification. I haven't checked to see what I need to do to fix it yet, but here's the output that followed that command, if anyone else would like to take a look at it:

$ sudo make install
Making install in man
Making install in man4
make[3]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/man4" || /bin/sh ../../mkinstalldirs "/usr/local/share/man4"
mkdir /usr/local/share/man4
 /usr/bin/install -c -m 644 './twconfig.4' '/usr/local/share/man4/twconfig.4'
 /usr/bin/install -c -m 644 './twpolicy.4' '/usr/local/share/man4/twpolicy.4'
Making install in man5
make[3]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/man5" || /bin/sh ../../mkinstalldirs "/usr/local/share/man5"
mkdir /usr/local/share/man5
 /usr/bin/install -c -m 644 './twfiles.5' '/usr/local/share/man5/twfiles.5'
Making install in man8
make[3]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/man8" || /bin/sh ../../mkinstalldirs "/usr/local/share/man8"
mkdir /usr/local/share/man8
 /usr/bin/install -c -m 644 './siggen.8' '/usr/local/share/man8/siggen.8'
 /usr/bin/install -c -m 644 './tripwire.8' '/usr/local/share/man8/tripwire.8'
 /usr/bin/install -c -m 644 './twadmin.8' '/usr/local/share/man8/twadmin.8'
 /usr/bin/install -c -m 644 './twintro.8' '/usr/local/share/man8/twintro.8'
 /usr/bin/install -c -m 644 './twprint.8' '/usr/local/share/man8/twprint.8'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in src
Making install in cryptlib
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in core
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in db
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in fco
g++ -DHAVE_CONFIG_H		 -I. -I. -I../.. -I..  -I/usr/local/include   -O -pipe -Wall -c -o fcodatasourceiter.o fcodatasourceiter.cpp
In file included from fcodatasourceiter.h:50,
                 from fcodatasourceiter.cpp:41:
fconame.h:147: error: ISO C++ forbids declaration of ‘cFCOName_i’ with no type
fconame.h:147: error: expected ‘;’ before ‘*’ token
make[2]: *** [fcodatasourceiter.o] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1


[ Reply to This | # ]
Install and configure Tripwire from source
Authored by: sittered on Jan 12, '10 11:01:29AM

I received the same output after `sudo make install`. Also running 10.6.2.



[ Reply to This | # ]
Install and configure Tripwire from source
Authored by: parraccourci on Jan 12, '10 02:11:58PM

Me too.



[ Reply to This | # ]