Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'apache wont start' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
apache wont start
Authored by: John Kiniston on Sep 13, '02 02:26:32AM

I un-commented the two dav related lines in my httpd.conf and now my apache wont start.

dyld: /usr/sbin/httpd Undefined symbols:
_XML_ErrorString
_XML_GetErrorCode
_XML_Parse
_XML_ParserCreate
_XML_ParserFree
_XML_SetCharacterDataHandler
_XML_SetElementHandler
_XML_SetUserData
/usr/sbin/apachectl: line 171: 435 Trace/BPT trap $HTTPD -t

any suggestions?

Darwin iguana 6.0 Darwin Kernel Version 6.0: Sat Jul 27 13:18:52 PDT 2002; root:xnu/xnu-344.obj~1/RELEASE_PPC Power Macintosh powerpc



[ Reply to This | # ]
apache wont start
Authored by: froz on Sep 13, '02 03:43:24AM

Looks like you have a broken mod_dav. It should have been statically linked with expat, or there should be a dynamic libexpat in /usr/libexec/httpd - I can't tell for sure because I have a pre-release of 10.2.1 and Apple has been moving libs around.

The info here: http://www.stepwise.com/Articles/Workbench/2002-04-05.02.html may be of help in getting it to work if you have the Developer Tools installed.



[ Reply to This | # ]
apache wont start
Authored by: JerkyJerk on Sep 13, '02 10:40:38AM
I have a question are you using the PHP module from Marc Liyanage's site? on my powerbook that's the one I'm using but my iMac is a stock install. I don't get that error on the iMac or I don't get the error if I disable the PHP module on my PowerBook. I compiled my own mod_dav and that didn't help. My next step is I'm gonna compile my own PHP module.
jerky

[ Reply to This | # ]
apache wont start
Authored by: jgmanning on Sep 13, '02 11:37:46AM

the PHP module from Marc Liyanage's site

Marc has confirmed that there's a conflict. Presumably the php module supplied by Apple will work with mod_dav.

I have found what appears to be a conflict between your PHP4 module and the WebDAV server included in 10.2. When both mod_dav your module are enabled, httpd restart fails with a bunch of XML errors.

I know, the two conflict... Not much I can do about it right now... You have to choose one or the other... There's a similar conflict with the apple_auth module.


[ Reply to This | # ]
apache
Authored by: JerkyJerk on Sep 16, '02 05:44:55PM
I can say for sure the Apple mod_php works with DAV.
jerky

[ Reply to This | # ]
apache
Authored by: srelan on Sep 17, '02 02:08:46PM

where can you get the apple mod_php (if you've already replaced it with mark Linage's module)



[ Reply to This | # ]
apache
Authored by: Goeres on Sep 22, '02 01:35:30PM
if you check Marc Liyanage page he suggests to load his PHP module only AFTER you load the DAV module (same for addmodule). At least his work for me and I am able to start apache again. I still have not been able to upload my calendar from ical but I have still the night a head.
regards
Robert

[ Reply to This | # ]
apache wont start
Authored by: westin on Sep 24, '02 03:49:30PM

Make sure you use Marc's Jaguar compile of PHP. Also make sure DAV is enabled and loaded after PHP



[ Reply to This | # ]
apache wont start
Authored by: chrispar on Oct 02, '02 06:46:37AM

This worked for me. I'm using Marc's PHP4 module and apache wouldn't restart until I changed the order of LoadModule and AddModule to force PHP to load FIRST.



[ Reply to This | # ]