Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.6: Install fish shell on an upgraded version of 10.6' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.6: Install fish shell on an upgraded version of 10.6
Authored by: wfolta on Nov 15, '09 03:10:50PM

I ran into problems when I was attempting to upgrade some other software. One issue is if you need both 32-bit and 64-bit versions of a library. On Intel Mac's this is known as "Universal". ("Universal" used to mean both Intel and Motorola binaries, I believe.)

To force the second version to be installed, when you already have one -- which I could never do from a GUI -- try something like:

sudo /opt/local/bin/port -vf upgrade --enforce-variants libiconv +universal



[ Reply to This | # ]