Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Install Ruby 1.9 alongside Ruby 1.8' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Install Ruby 1.9 alongside Ruby 1.8
Authored by: rfzabick on Oct 16, '09 10:40:14AM

I tried the macport approach. Now I have ruby binaries with a 1.9 suffix in my /opt/local/bin. But my old 1.8 binaries are already in that directory without suffixes. Should I rename the 1.8 binaries with a suffix and then remove the suffix from the 1.9 binaries?

How does this install affect my gems? What if I rename the binaries as described above? How will that affect my gems?

I've spent a fair amount of time googling this, but I can't find anywhere that describes how to handle the admin side of ruby and its upgrades.



[ Reply to This | # ]