Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.6: Install Canon printer drivers in Snow Leopard' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.6: Install Canon printer drivers in Snow Leopard
Authored by: iMattUK on Sep 02, '09 07:51:18AM
Guys, I just installed 10.6 and found my i-Sensys LBP5000 was no longer supported. A search online by the Apple printer utility failed to find a driver. I searched the web, various forums, etc. and found this thread and the official Canon stuff which indicates that the LBP-5000 isn't supported. As a last ditch effort I rang Canon and paid for a guy to tell me my printer isn't supported and that I should revert to 10.5...!

The reality is that with this printer, all you actually have to do is re-run the CAPT v1.70 installer again after the upgrade:

http://software.canon-europe.com/software/0028785.asp?model=

If you installed it on Mac OS X 10.5 Leopard, you may still have the file CANON_CAPT_V170_EN.dmg on your home area. Look in your downloads folder or do a Spotlight search; otherwise download again.

You'll need to reboot after reinstalling, but after that you should find that if you add a new printer you can select the LBP-5000 (it will show "CAPT Driver" as the driver).

I've successfully printed photos from Aperture and text from TextEdit with this driver, so everything seems to working just as well as it did on 10.5 Leopard.

The only remaining question is why on earth Canon's website and their own support staff don't know this and aren't passing the simple info on to their own customers!

Hope that helps someone.

Cheers.

[ Reply to This | # ]