Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Fix a broken Perl install after 2009-01 Security Update' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Fix a broken Perl install after 2009-01 Security Update
Authored by: delux on Feb 23, '09 07:50:02PM
If you installed Perl with Fink or MacPorts, you're not necessarily immune to the Apple's Camel Killer update. If you are using such an alternative location, as is recommended my other discussion boards as a way to avoid such vender update problems, the solution presented here may not work. My main perl installation was in /opt/ but for some reason perl referred to /System/ and /Library/'s IO. Reinstalling IO just updated the version in /opt/. I couldn't get Make to change the destination without a bunch of extra work. Now I'm looking at spending some long hours getting ImageMagick and the infinite dependency tree working again.

[ Reply to This | # ]