Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Use a D-Link DWL-G122 USB WiFi Dongle' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Use a D-Link DWL-G122 USB WiFi Dongle
Authored by: jalden81 on Dec 09, '08 07:08:20AM
I've been looking thru many of these posts trying to figure out whats wrong with my DWL-G122 for my Mac g4 running OSX 10.4. I had version B1 for 2+ years that worked great with little or no connection drops (I used this driver: http://tsd.dlink.com.tw/ModelDocuView.asp?SourceType=download&ModelSno=NSITIP&DocuSno=IJLPCJIK ). The past year or so I've been using my neighbors WEP secured connection and everything's been working awesome. About a month ago the DWL USB died on me. I figured it was just kaput after a long life, so I purchased another..this time it was version C1. Once I got it and plugged it in its been nothing but problems. I downloaded the C1 driver with no luck, tried different chipsets..and the dongle still will not connect. I ended up sending back the C1 version and getting the B1 version again, with the same results. The device will show up in Network Prefs as an ethernet connection but there will be no signal or lights on from the device. It's like my computer fogot that this device works with it. I've uninstalled, deleted prefpanes, re-installed, and tried many different combos with no wifi. I know the signal is there because my GF's laptop works great. Has anyone had similar problems and found a solution? Could it be something with the router that's seeing the device but not letting it connect? Thanks a lot for your help and please let me know any questions.

Regards!

[ Reply to This | # ]