Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Site upgrade progress notes Site News
Some notes after a day of working on the assorted upgrade-related issues here:
  • I've made some changes to search, so that it works a bit more like the older version (year added to date display, author column removed, etc.). It's not perfect, but I expect we'll see more improvements in the near future. (I've opened a feature request for better control over search.)
  • Search does, however, have a date-related issue right now. If you order results by date, the output is seemingly random. I've opened a bug with the Geeklog team, and it's being investigated.
  • Searching for words with special characters, such as Exposé, no longer crashes the search engine.
  • Activated a titles-only search -- it's a checkbox on the advanced search page. If you haven't tried it yet, it's quite useful for narrowing down hint results.
  • Those who are seeing a narrow side column should now be seeing it at the desired width again.
  • Fixed a huge problem with the My Account pages. Basically, no changes were taking, which is a bad thing. This should all be resolved now; please let me know if you see any lingering issues.
  • Fixed a large number of character issues. No, not mine, but Geeklog's. I've searched and replaced all of the following: é; smart single and double quotes; …; « and » in text and AppleScript class statements; ¬ in AppleScripts; and em-dashes.
Aside from the search engine issues, the other big problem right now has to do with code snippets in comments and the submission page. It works strangely, but it does basically work -- you'll find your HTML characters get changed to entities in the input box, and they may preview as entities, but they'll publish correctly. I've opened a bug on this. The one exception is any code snippets within angle brackets -- that text will just vanish unless you use the special [code] tags. So please use that tag for any code in your hint. (For the first time here in nearly forever, backslashes will not be eaten, so that's something!)

-rob.
    •    
  • Currently 2.36 / 5
  You rated: 3 / 5 (11 votes cast)
 
[3,905 views]  

Site upgrade progress notes | 23 comments | Create New Account
Click here to return to the 'Site upgrade progress notes' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Site upgrade progress notes
Authored by: asmeurer on Oct 17, '09 08:47:14PM
The side column itself seems to be a good width, but the names of the hints under the comments text are very truncated. For example, I currently see:
Comments last 2 days
Site upgrade comp... [+47]
10.6: Create netw... [+4]
10.6: Quit and hi…
Command-click on …
"Command-click on…" That isn't very descriptive. Fortunately, hovering over it gives alt-text for the complete hint title.

[ # ]
Site upgrade progress notes
Authored by: robg on Oct 17, '09 11:04:33PM

Ah yes; forgot to change that. Should be better now.

thanks!
-rob.



[ # ]
Site upgrade progress notes
Authored by: fenlyn on Oct 17, '09 11:26:43PM

The irony is that words like Expose (with the accent) don't display correctly via RSS. I have the same problems on my own site.



[ # ]
Site upgrade progress notes
Authored by: robg on Oct 18, '09 07:05:30AM

I've got that on the list...

-rob.



[ # ]
Site upgrade progress notes
Authored by: V.K. on Oct 18, '09 06:54:02AM

please make it possible to change votes when rating a hint. that was possible before but not now. sometimes I simply mis-click and give a wrong rating.



[ # ]
Site upgrade progress notes
Authored by: chucky23 on Oct 18, '09 08:15:30AM

You might want to acknowledge that some of your readers surf with Javascript turned off, and not have the new main page look so out of control with Javascript disabled.

I understand this isn't anyone's highest priority, but the new site looks worse with Javascript disabled than any other Mac site I'm familiar with.



[ # ]
Site upgrade progress notes
Authored by: robg on Oct 18, '09 08:19:23AM

With Javascript (and Java) off, the only thing I see different is that the story voting block takes up a chunk of vertical space. I don't believe I can easily change that, but I'll dig into it a bit.

What other weirdness are you seeing?

-rob.



[ # ]
Site upgrade progress notes
Authored by: chucky23 on Oct 18, '09 08:38:42AM

Bingo. Seems fixed now.



[ # ]
Site upgrade progress notes
Authored by: masterluc on Oct 18, '09 12:43:23PM

your page of course lives on my top sites page! but for macosxhints, the "new-content-white-star-on-blue corner" appears far too often, rendering it useless. this is not new behaviour - i just hoped the site upgrade would be an opportunity to look into that. thx!



[ # ]
Site upgrade progress notes
Authored by: robg on Oct 18, '09 07:35:42PM

I think you'd need to talk to Apple about their algorithm for the "new content" stuff -- there's not a lot here that changes, other than the "what's new" box showing recent comments, and the forum post block ... and the ads, of course.

I would hope Apple's algorithm would be smart enough to account for the ads. As a registered user, you could disable the What's New and What's New in the Forums boxes and see if that makes a difference.

-rob.



[ # ]
Site upgrade progress notes
Authored by: masterluc on Oct 18, '09 11:42:53PM

all these news-boxes are disabled for me. ads are filtered via glimmerblocker. afaik "new content" is RSS-based. "mac os x hints" offers two feeds, "new comments" and "new hints". top sites seems to be triggered by both of them.



[ # ]
Site upgrade progress notes
Authored by: robg on Oct 19, '09 04:53:04AM

Ah right, it is RSS based. I can only think then that it's something that's done by our feed provider, and that's nothing I have any control over.

Sorry about that.

-rob.



[ # ]
Site upgrade progress notes
Authored by: masterluc on Oct 21, '09 05:44:32AM
i solved it!

find "Library/Safari/TopSites.plist" in your user's home.
(if you need, duplicate it to a safe place somewhere else.)
then open the original file with "Property List Editor".

in the array "TopSites," you will find all of them listed by numbers.
for macosxhints.com, change the field "TopSiteFeedURLString"
from "feed://www.macosxhints.com/backend/commentfeed.rss"
to "feed://www.macosxhints.com/backend/osxhints.rss".

that's it. is that hint-worthy?
luc

[ # ]
Site upgrade progress notes
Authored by: robg on Oct 21, '09 09:27:07AM

Seems Safari was marking the comment feed (changes a lot), instead of the site feed (changes rarely).

-rob.



[ # ]
Site upgrade progress notes
Authored by: masterluc on Oct 21, '09 09:43:13AM

that is exactly what i thought. i suspect safari just uses the last link it finds in the head when it first scans the page, which seems a fair strategy. you can change that setting manually later on, for now it seems to stick. i will still have to run some tests to prove both theories. luc



[ # ]
Site upgrade progress notes
Authored by: Andreas. on Oct 18, '09 06:07:32PM
I can't help with the character problem, but I can offer a clue...

An anagram of "Geeklog team" is Make e-toggle.

Just trying to be helpful.

Andreas

[ # ]
Site upgrade progress notes
Authored by: everkleer80 on Oct 19, '09 01:59:32PM

It seem my feed to osxhints.rss no longer works (in Outlook 2007 on Windows) - I'll try it on my mac when I get home in an hour. I tried subscribing to other feeds here and it worked though. I tried resubscribing to osxhints and it said "Outlook cannot process the RSS content from http://feeds.macosxhints.com/macosxhints/recent. The link may not point to a valid RSS source." (This is the first time I've tried it since the upgrade. It was working on Fri.)



[ # ]
RSS Feed error
Authored by: everkleer80 on Oct 19, '09 03:27:15PM

Hmm.. maybe it's something cached in Outlook or something... I'll have to look at it some more tomorrow.



[ # ]
RSS Feed error
Authored by: everkleer80 on Oct 20, '09 01:22:48PM

Still can't get it... anyone else have trouble using Outlook with the main hints feed? It's only that one; the others work ok.



[ # ]
RSS Feed error
Authored by: everkleer80 on Oct 21, '09 09:21:38AM

Hmm.. seems to work ok today..



[ # ]
Site upgrade progress notes
Authored by: David Allen on Oct 19, '09 02:25:30PM

I tried to upload a photo and all it did was churn away forever and never saved it.

---
Dah•veed |David Allen|
Monterrey, NL, Mexico



[ # ]
Site upgrade progress notes
Authored by: MJCube on Oct 19, '09 03:10:09PM
1. I thought I’d try changing themes, but I can’t find it anywhere. Under the “Layout and Language” tab, in a box labeled “Misc settings,” there’s a little yellow box once again headed “Layout and Language” with a bullet that says “Set your theme, timezone and perferred date format”. But no choice of theme to be found.

2. My time zone and date format settings have no effect. I will be very glad to have these choices when they work.

3. I agree with those who have said that Nested should be the default display mode for users not signed in.

Thanks again Rob!

[ # ]

one small issue
Authored by: tedw on Oct 20, '09 09:02:46AM

I just noticed today that if you click on a link to a comment from the RSS feed, the resulting page is missing the 'parent' link that normally lives between the 'Reply to this' and 'Report abuse' links. This seems to be true if you click the '#' (permanent link) link, as well.



[ # ]