Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.6: Exposé won't collect windows in App Windows mode System 10.6
This is another notice of a change in Exposé's behavior in 10.6 -- one that I find rather annoying.

If you choose the Application Window mode (F10 by default), it (as expected) shows all the windows from the current application. But when you leave Exposé, all of these windows are left on the same "layer" they existed on prior to invoking Exposé. In 10.5, when you left All Windows mode, all of the current application's windows were brought to the front. I routinely used this feature of Exposé to achieve this particular goal.

[robg adds: I tried holding down various combinations of the modifier keys while exiting Exposé, but nothing would pull all the app's windows to the same frontmost layer.]
    •    
  • Currently 2.08 / 5
  You rated: 5 / 5 (12 votes cast)
 
[5,208 views]  

10.6: Exposé won't collect windows in App Windows mode | 10 comments | Create New Account
Click here to return to the '10.6: Exposé won't collect windows in App Windows mode' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.6: Exposé won't collect windows in App Windows mode
Authored by: asmeurer on Sep 29, '09 07:56:57AM

This too has annoyed me, as it was my chief use of Exposé in earlier versions of Mac OS X. Maybe there could be some kind of workaround using a keyboard shortcut with Snow Leopard services.



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: Geobunny on Sep 29, '09 08:21:00AM
Yes, this used to annoy me too. With keyboard shortcuts, I assigned command-shift-A to the "Bring All to Front" menu item for all applications. It works as a kludge but it's still an extra step which wasn't needed before.

I started this post saying 'used to' because I found this and the new window placement algorithm of the new Exposé so infuriating that after a month, I used Time Machine to go back to 10.5.8! I'm now a much happier bunny.

[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: unforeseen:X11 on Sep 29, '09 09:32:44AM

A workaround would be nice, I also miss this possibility!

---
this is not the sig you`re looking for.



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: brh on Sep 29, '09 08:21:51AM

Cmd-tab switching pulls all windows of the selected app to the front… Can't you just use that? If it's the application you're already in just do a quick cmd-tab/backtick…



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: acaltabiano on Sep 29, '09 08:37:41AM

Another thing I noticed about app-specific Exposé in 10.6 is that if you have different windows in different spaces and you activate it, it will show you ALL the windows from ALL the spaces. Which is cool, except that I wish it would somehow indicate which windows are from the non-current space. Minor I know, but would be better.

Also, I like how if you activate exposé (all windows or app) and there's a window in the dock, if you chose that window it will pop open in WHATEVER SPACE YOU'RE IN, rather than forcing you to move to the space it was originally minimized in. Good for me because I always tought that the Dock — since it appears in all spaces and is semi-separate from the paradigm — should act as a transport BETWEEN them rather than move you between them when selecting DOCUMENTS (not programs) from it.

Just clicking documents/folders out of the dock still moves you to the original space, so now you have the option, which is good.

---
timing has an awful lot to do with the outcome of a raindance
http://www.randombob.net



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: jcrossley on Sep 29, '09 03:41:37PM

Perhaps I'm missing something here. I find that a simple, single click on the dock icon for the application brings all windows for that application to the front in all spaces.



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: asmeurer on Sep 29, '09 07:22:11PM

It's way easier to just bump your mouse into a screen corner twice than to try to find the Application you are using in the dock and click on it. The same for a keyboard shortcut.



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: acaltabiano on Sep 30, '09 10:28:32AM

You're missing something here. What's being described is this: in pre10.6, when you activated app exposé, all the windows come forward for you to view (nothing's changed in snow leopard). Previously though, when you made your selection from there, ALL OF THOSE SAME APPLICATION WINDOWS WERE NOW THE FRONTMOST WINDOWS, even if previously they were buried deep below the windows of other apps (now in SL, they go back to the same window depth they were at, meaning if you had 4 Safari windows open but one was buried behind 20 other windows, and you DON'T select this window in expose, now it will go back to being 20 windows deep and out of view).

---
timing has an awful lot to do with the outcome of a raindance
http://www.randombob.net



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: illustratedlife on Nov 25, '09 11:11:28AM

By default, the buttons on a Wacom tablet pull up Exposé. I developed muscle memory double-tapping the current-app-Exposé button with my pen if I needed to pull up a window. It was pretty rad.

Here's how I recreated it:
- As Geobunny suggests, I mapped "Bring All to Front" to a keystroke. I chose F9, as it seems to have no other function in the apps I use.
- In the Pen Tablet control panel, I remapped the button to "F9 F3." It was previously just F3.

Now, double-tapping the button brings all the windows to the front in apps that have that menu item, which most do. AIR and Cocoa apps both seem to include it by default - the only apps I have that don't expose this menu item are the Adobe ones.



[ Reply to This | # ]
10.6: Exposé won't collect windows in App Windows mode
Authored by: grossbart on Apr 28, '10 12:35:26PM

There is a solution over here:

http://forums.macrumors.com/showthread.php?t=869611

I feel productive again!



[ Reply to This | # ]