Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.6: Java 1.6 works on all Intel Macs in Snow Leopard System 10.6
One problem with using an Intel Core Duo Mac is the inability to use JRE 1.6. The JRE 1.6 update was limited to 64-bit chips only, which really ticked me off. After upgrading to Snow Leopard, a friend mentioned to me to check my Java version. Low and behold, java -version in Terminal reported back 1.6.

Running the Java Preferences application in the Utilities folder clearly states to me that it is a 32-bit build, so there was no reason for us early adopters not to have JRE 1.6 in the first place. So if you need JRE 1.6 and were an early adopter, then you need to pony up for Snow Leopard to get the update. I can confirm that Java apps that didn't work in Leopard now work, as I now have a current build of JRE.
    •    
  • Currently 2.27 / 5
  You rated: 3 / 5 (11 votes cast)
 
[17,944 views]  

10.6: Java 1.6 works on all Intel Macs in Snow Leopard | 5 comments | Create New Account
Click here to return to the '10.6: Java 1.6 works on all Intel Macs in Snow Leopard' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.6: Java 1.6 works on all Intel Macs in Snow Leopard
Authored by: jeremyp on Sep 23, '09 09:05:01AM

It should be pointed out that, under Snow Leopard, Java 1.5 disappears completely. If you need Java 1.5 (as I do for an application that crashes regularly under 1.6), you'll need to reinstall it manually.



[ Reply to This | # ]
10.6: Java 1.6 works on all Intel Macs in Snow Leopard
Authored by: Anonymous on Sep 23, '09 11:28:15AM

GimpShop is another solution, for those who prefer Photoshop terminology. There are others too.



[ Reply to This | # ]
10.6: Java 1.6 works on all Intel Macs in Snow Leopard
Authored by: Anonymous on Sep 23, '09 11:39:22AM

What the hey? I thought I was replying somewhere else! oh well.



[ Reply to This | # ]
10.6: Java 1.6 works on all Intel Macs in Snow Leopard
Authored by: rmanke on Sep 23, '09 05:55:03PM

I found the description of this tip a bit confusing because it talks about 1.6 being limited to 64 bit, and then mentions that the one in Snow Leopard is 32 bit.

You might want to clarify to readers that the one in Snow Leopard is both 32 and 64 bit.



[ Reply to This | # ]
10.6: Java 1.6 works on all Intel Macs in Snow Leopard
Authored by: aafuss on Sep 23, '09 07:15:03PM

Can confirm this as well-I'm using a Core Solo Mac mini:
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) Client VM (build 14.1-b02-90, mixed mode)



[ Reply to This | # ]