Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Where to find Flash Player 9 for older versions of OS X Web Browsers
Over on our forums, user shawbeg writes:
A couple of sites I use are asking for an upgrade to Flash Player 9.0.115 to run certain apps (Snapfish & Facebook, for example). I'm running OS X 10.3.9 which is not compatible with Flash Player 10. Can I still get Flash Player 9.0.115? I've got 9.0.47 now. Not finding what I want digging around on the Adobe site.
As it turns out, it is available, but apparently not on the Adobe site. User macosnoob found it on macromedia.com -- caution, this is a 134MB download link: Adobe Flash Player 9.0.115. If you're running an older Mac and need the last version of Flash Player 9, the above link should get the job done.
    •    
  • Currently 2.29 / 5
  You rated: 1 / 5 (14 votes cast)
 
[76,250 views]  

Where to find Flash Player 9 for older versions of OS X | 5 comments | Create New Account
Click here to return to the 'Where to find Flash Player 9 for older versions of OS X' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Where to find Flash Player 9 for older versions of OS X
Authored by: mat79 on Dec 11, '08 08:14:12AM
btw: here is a list of all older Flash versions that are still available:

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14266


[ Reply to This | # ]
Where to find Flash Player 9 for older versions of OS X
Authored by: iglazer on Dec 11, '08 08:32:40AM
I documented my Flash 10 to Flash 9 downgrade process, with download locations here

[ Reply to This | # ]
You only need the 6MB download
Authored by: Uncle Asad on Dec 11, '08 06:22:21PM

You don't need to download the entire 134MB package; just download the 6MB version from http://kb.adobe.com/selfservice/viewContent.do?externalId=kb406791&sliceId=1.

Even better, it's not a crappy Adobe installer; it's just the binaries you need!



[ Reply to This | # ]
You only need the 6MB download
Authored by: Hamo on Dec 11, '08 06:32:40PM

Just drop those files in your Library/Internet Plug-Ins folder and you should be good!
**Make sure to use verion 9.0.151 (not 115) as it contains important security fixes.**



[ Reply to This | # ]
Re: You only need the 6MB download
Authored by: Uncle Asad on Dec 11, '08 06:34:31PM

Oops, I forgot to note that the link I mentioned is for the *latest* Flash 9, Flash 9.0r151, which has the patch for the November Flash security bulletin.

robg mentions in the story that the 134MB download gets you the (unpatched) Flash 9.0r115; I don't want to download 134MB just to verify he didn't make a typo. ;-)



[ Reply to This | # ]