Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.5: Use Apple Remote Desktop 2.2 under 10.5 Apps
If you are frustrated by Apple's insistence on upgrading your copy of Apple Remote Desktop to run on your 10.5 machine, do the following:

Install Apple Remote Desktop 2, then install the Apple Remote Desktop Updater to v2.2. Now run Applications » Remote Desktop and enter your serial number. Remote Desktop will now give you the message that it cannot install due to a newer version. In the Finder, navigate to:

/System/Library/CoreServices/RemoteManagement

From the folder, delete (or move) the ARDAgent v3.X file. You can now run Remote Desktop 2.2 in 10.5 -- sweet!

[robg adds: I haven't tested this one, and there may be things that don't work properly using an older version of ARD in 10.5. Proceed at your own risk.]
    •    
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[10,255 views]  

10.5: Use Apple Remote Desktop 2.2 under 10.5 | 4 comments | Create New Account
Click here to return to the '10.5: Use Apple Remote Desktop 2.2 under 10.5' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.5: Use Apple Remote Desktop 2.2 under 10.5
Authored by: RickD on Nov 15, '07 10:43:29AM

I have tested this and it does indeed work. I had to temporarily shut off "Remote Management" under the Sharing preference in System Preferences. After you delete the ARDAgent(.app) file and then start ARD, it installs the v2.2 ARDAgent(.app) file in its place. You can then restart "Remote Management" if you like.

This is a great tip if you have ARD v2.2 and were suddenly hung out to dry.



[ Reply to This | # ]
10.5: Use Apple Remote Desktop 2.2 under 10.5
Authored by: jtnt on Feb 15, '08 05:58:00AM

Looks like you have to repeat the process of removing ARDAgent, running ARD, etc. again after the 10.5.2 update, but it works just the same.



[ Reply to This | # ]
10.5: Use Apple Remote Desktop 2.2 under 10.5
Authored by: pub3abn on Feb 08, '10 06:13:33AM

This hint also allows the software to run under 10.6 Snow Leopard. (I have successfully run it under 10.6 myself, but only once so far, so cannot say much about reliability, etc. It did seem to work perfectly though.)

NOTE: In the hint, the path is misspelled. It should be:
/System/Library/CoreServices/RemoteManagement

Edited on Feb 08, '10 06:16:21AM by pub3abn



[ Reply to This | # ]
10.5: Use Apple Remote Desktop 2.2 under 10.5
Authored by: robg on Feb 08, '10 01:23:42PM

Thanks; fixed that.

-rob.



[ Reply to This | # ]