Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Use Entourage with Exchange Server 2007 Network
Recently, my company implemented a new Exchange 2007 server for our email. No special changes or accommodations were made to support OS X. After a bit of searching and trial and error, I figured out the settings for Entourage to work when connected to the corporate network: email, contacts, and calendar all work.

I started with version 11.3.6 (070618) of Entourage, and added a new Exchange email account. I then tried the automatic setup, but it failed so I went into manual mode. During the setup, i found two fields that require surprising entries:
  1. Under the Account Settings tab, the Exchange Server field. Here is what works for me:
    https://my.internal.owa.server.name/exchange/username@domain.com
    Be sure to use /exchange/ rather than some other directory, and include your full email address afterwards. This was surprising because to connect with Safari, the URI is:
    https://my.internal.owa.server.name/owa/
  2. On the Advanced tab, for the Public folders server, I use this URI:
    https://my.internal.owa.server.name/public/username@domain.com
    Once again, use /public/ not some other directory.
Evidently /exchange/and /public/ are virtual folders that Exchange 2007 creates for backward compatibility. The data for the rest of the fields was as expected. Hope this helps!
    •    
  • Currently 4.46 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (13 votes cast)
 
[49,898 views]  

Use Entourage with Exchange Server 2007 | 8 comments | Create New Account
Click here to return to the 'Use Entourage with Exchange Server 2007' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Use Entourage with Exchange Server 2007
Authored by: adamchernow on Aug 22, '07 09:09:15PM
Be sure to use /exchange/ rather than some other directory, and include your full email address afterwards. This was surprising because to connect with Safari, the URI is: https://my.internal.owa.server.name/owa/

Interesting... I've also seen OWA live at an address like https://mail.domain.tld/exchange/ (or at least I believe that's how it worked in college)

-A

---
---
Blogging @ http://www.commanddotcom.com

[ Reply to This | # ]

Use Entourage with Exchange Server 2007
Authored by: rwmarvin on Aug 25, '07 06:47:45AM

Thank you! I have been trying to get this to work for a while. Our IT group doesn't support Macs well, so this has been problematic.



[ Reply to This | # ]
Use Entourage with Exchange Server 2007
Authored by: tjfoz on Sep 18, '07 01:10:01PM

We have had our Macs connected via Entourage on our Exchange Server for about 4 months now. Last Wednesday (9/12/07), they stopped being able to receive mail via Entourage. There doesn't seem to be a rhyme or reason. The server was restarted the night before, but not for updates. Not all of our Macs received an update that day. Nothing changed from one day to the next. I get varied errors when trying to connect, from the root certificate error (I have tried reinstalling the certificate), to a network error (but they are able to ping the server and connect to other network servers). Anyone have any ideas for what else I could try? I tried using the hint in this post as well.

Thanks for any help you can offer!



[ Reply to This | # ]
Use Entourage with Exchange Server 2007
Authored by: devrock on Sep 25, '07 08:56:02AM

tj, make sure the admins have IIS turned on and OWA activated. We discovered that Entourage actually uses OWA to retrieve mail, etc.

Exchange 2007 is horrible. I'm hoping Entourage 2008 works with it correctly. We're having a bear of a time with certificates (we now have to install these certs on ALL our Macs?????) and not working with Treos. Exchange 2003 worked just fine. We may even downgrade to '03 in order to get things to work correctly. Even the anti-virus/spam packages from Trend Micro and Symantec aren't fully compatible with this garbage and it's been out for 9 months.



[ Reply to This | # ]
Use Entourage with Exchange Server 2007
Authored by: ctwise on Mar 10, '08 11:55:49AM

This is exactly the information I was looking for to connect w/Exchange using Entourage. I'm amazed at how poor the setup assistance is with Entourage and Exchange. There's absolutely nothing on the Microsoft site that would hint at this information.



[ Reply to This | # ]
Use Entourage with Exchange Server 2007
Authored by: DrMacMusic on Apr 14, '08 02:35:53PM

Yay! This worked for me too. I never would have Why does Microsoft make this so hard?



[ Reply to This | # ]
Use Entourage with Exchange Server 2007
Authored by: creatino on Nov 11, '08 08:40:58AM

Hey guys.

Has anyone tried this with Entourage 12 (Office 2008), OSX 10.5.5 and a 2007 Exchange server yet? I'm trying everything but already failing at the keychain access part already since the dialogue looks different to what you are describing when I add my domain's certificate to Keychain Access... although I have found a way to set the X509 value to Allow it still doesnt work.

Any help at all would be very much appreciated!



[ Reply to This | # ]
Use Entourage with Exchange Server 2007
Authored by: creatino on Nov 11, '08 09:19:55AM

Ignore my last comment, it now works with the config listed above.

The problem was with my keychain addition, I added the certificate to the "System" keychains folder and then set the info on the entry to accept anything from this domain, IP, X509, etc: whether that second part is necessary I do not know, but now that it is working im not going to touch it :-)

I will now try using your trick in Apple Mail and see how the integration with iCal etc. works (hahaha i am an optimist i know!)

Thank you SO much for your post we would have NEVER figured that one out over here, and I would now probably be running parallels just to access my company mail.



[ Reply to This | # ]