Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: A fix for the modem GUI not showing completed jobs System 10.4
I recently had the experience that my internal modem did not show my sent faxes anymore. As soon as I clicked on Completed Jobs within the internal modem.app, the window became sluggish and did not react anymore. I finally found out that it had something to do with one of the earlier jobs that was not sent properly. These jobs are stored in /var » spool » cups and begin with somewhat like c0*.

In addition to that, there is a wonderful CUPS administrative view that you access with your browser via http://localhost:631 that I hadn´t seen before. There you'll find your printers, but also your internal modem and all the jobs that have ever been faxed with it. One of these jobs had to be my "killer." Note that this job list is generated dynamically at startup of the cups daemon. If you mangle around with the job files (moving or deleting), you won´t see a result until you restart the daemon with sudo killall -1 cupsd.

So I moved the jobs according to the number within the job list shown within the browser GUI (easy: the job named printer-1136 would be found as c01136 in /var/spool/cups), one by one. After each move, I restarted the cups daemon and -- bingo -- problem solved when I finally found the broken file and could see my sent faxes again.

To move or delete files within /var/spool/cups, you must have admin rights. I like to provide myself with full rights by opening the shell via sudo (sudo csh then enter password). There's no more need to authenticate, but be very careful, as the system is now completely in your hands!

[robg adds: We've covered the CUPS admin web interface before, and for something like this, I'd probably just use sudo on the file(s) to be deleted, instead of using a full-on root shell -- because I don't trust myself!]
    •    
  • Currently 2.20 / 5
  You rated: 1 / 5 (5 votes cast)
 
[7,752 views]  

10.4: A fix for the modem GUI not showing completed jobs | 0 comments | Create New Account
Click here to return to the '10.4: A fix for the modem GUI not showing completed jobs' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.