Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Fix a Vista to Mac failure to connect problem Network
Basically I was unable to connect from my PC running Vista to Windows sharing on my Mac -- doing the normal ipaddressusername and supplying username and password failed. Vista seemed convinced that I'd entered an invalid username and/or password, regardless of what I tried. After much searching, I found the solution in this thread on vista64.net's forums.

You need to go into the Administrative Tools and enter the Local Security Policy section. In that section, you need to change the LAN Manager Authentication Level to 'Send LM & NTLM responses.' If you need full details on the steps involved, see the above-linked post. This change will reduce the security level of your Vista installation, as it downgrades the authentication required for Samba connections -- making it the same as Windows XP.

When I made the change as described, I was able to connect to my Mac from Vista.

[robg adds: From some reading on another thread on vista64.com, it seems the problem is that Microsoft has disabled LM and NTLM authentication, which is what OS X's version of Samba uses. Microsoft's preferred solution is to upgrade to Samba 3, which supports NTLMv2, as does Vista. If you happen to be running Vista Home Premium, you won't have the Administrative Tools application (advanced home users don't need to administer their machines, I guess?). The thread I linked to contains a Registry Editor alternative for Home Premium users.]
    •    
  • Currently 2.80 / 5
  You rated: 1 / 5 (5 votes cast)
 
[72,338 views]  

Fix a Vista to Mac failure to connect problem | 8 comments | Create New Account
Click here to return to the 'Fix a Vista to Mac failure to connect problem' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Fix a Vista to Mac failure to connect problem
Authored by: Coumerelli on Apr 09, '07 08:49:55AM

Does this only work with 10.4? I've got a 10.3.9 Server (running a domain) that I cannot get Vista Ultimate (RC2, incidentally) to connect to. I need this to work before the company buys into vista on any level.

Anyone? I'll hop over to the forums and repost this, too.

---
"The best way to accelerate a PC is 9.8 m/s2"



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: jyu on Apr 09, '07 09:00:06AM

Do we know what version of OS X that shoutdown is running? Because I tried connecting from Vista Business -- a fresh install, no twist -- to both my OS X 10.4 server and 10.4 client and had no problem at all. OS X 10.4 already has Samba 3.0.10 installed.



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: gxw on Apr 09, '07 09:46:41AM

Ditto.
Vista ultimate to OS X 10.4.9 working great.
OS X 10.4.9 to Vista Ultimate working great.



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: andya on Apr 09, '07 01:51:50PM

10.4.x should work w/o the change; 10.3.x requires it. keep in mind your security isn't as good.



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: necrosis on Aug 08, '07 07:53:21AM

This is *THE WORST* way to handle this. You are lowering the security on Vista instead of raising the security of Samba.

You are better off enabling NTLMv2 support in Samba. Granted you need to have Samba v3+ in order to do this. As far as I know 10.4.x is running Samba 3.

Add 'client NTLMv2 auth = Yes' in the [global] section.



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: ewas on Feb 06, '09 09:27:11PM

I know this a comparatively ancient thread, but I was searching for an answer, so maybe it will help others…

In an additional twist, while using vista 64 connecting to 10.4.11, I found that I had to change the vista computer name to not contain a hyphen. So, computer name was eric-PC, and the policy NTLMv2 fix made no difference. I changed the name to ericpc (NTLMv2 change applied), and it started working.

For what it's worth…



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: bobilew on Aug 10, '09 07:58:41AM

this works I had the same problem with Vista home Premium. I had a hyphen in the vista name. worked fine after i removed the hyphen
THANKS



[ Reply to This | # ]
Fix a Vista to Mac failure to connect problem
Authored by: jb19012 on Aug 16, '09 05:09:48PM

I concur that hyphens are a REAL problem. Removing the hyphen in my PC's name fixed my networking problems! Thanks, Bill Gates! Go back to school!



[ Reply to This | # ]