Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: A fix for Photo Booth not quitting properly Apps
I recently found that after using Photo Booth on an MacBook Pro running 10.4.8, the app did not completely close out, preventing you from running it again without re-logging in.

What would happen is that the Photo Booth window would close, but the dock icon would indicate that it was running (and Command-Tab would show it still running as well). However, Activity Monitor would not list it, and trying to force quit the app from the Dock icon would have no effect. Also, trying to kill -9 the process from the command line had no effect. This prevented me from using Photo Booth again until I logged out and back in again.

A brief search found a request in these forums from a few people with the same problem, so I looked further into it. By switching to another account and running Photo Booth and examing it in Activity Monitor, I found that one of the files the app was using was /Library » Quicktime » macam.component. This was installed by an app called Macam, which allows QuickTime to use USB web cams. I had this installed before to test a camera for a Windows client.

Getting rid of this file solved the problem for me; Photo Booth now exits normally. I had to restart in single user mode and delete the file from the command line, as trying to do in whilst logged in to my account would give me the error that it was in use. I downloaded Macam again from Sourgeforge, but did not see an uninstaller package, or instructions on how to do so.

Hope this will help others who have been plauged by the same problem.
    •    
  • Currently 2.50 / 5
  You rated: 5 / 5 (4 votes cast)
 
[11,086 views]  

10.4: A fix for Photo Booth not quitting properly | 4 comments | Create New Account
Click here to return to the '10.4: A fix for Photo Booth not quitting properly' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.4: A fix for Photo Booth not quitting properly
Authored by: vdubya on Mar 02, '07 08:28:42AM

I had a similar problem, but different fix. My PhotoBooth started doing the same thing and I concluded it was a demo copy of SnapZ Pro. Uninstalling that app fixed the problem for me.

Perhaps there is a shared library file or something those two apps have in commone.



[ Reply to This | # ]
10.4: A fix for Photo Booth not quitting properly
Authored by: Eric33Toubib on Mar 03, '07 07:16:15AM

I have the same problem but don't use any of the two apps mentionned in the first two post... I use a MacBook with Parallels desktop for mac" and I suspect that the problem is with this app because it appears only when parallels is working when I'm using Photo booth. I don't find a fix for the moment.. Any idea ?



[ Reply to This | # ]
10.4: A fix for Photo Booth not quitting properly
Authored by: parkblvd on Mar 04, '07 03:26:25PM

I have neither of these apps, and Photo Booth fails to close every time I close it from within camera mode. It must be a shared library. I think it's unrelated to Quicktime, as I have no additional Quicktime components installed.



[ Reply to This | # ]
10.4: A fix for Photo Booth not quitting properly
Authored by: jinieJ on May 26, '07 06:46:16AM

I have this same problem but i dont use any of the apps, and the wierd thing is it only does it every other time or so.



[ Reply to This | # ]