Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: Fix a possible gutenprint issue under 10.4.8 Printers
Prior to installing 10.4.8, I was using cups 1.2.4 and gutenprint 5.0.0 to print to an Epson Photo R340 located on my Windows 2003 Server machine. After installing the 10.4.8 update, the print service was unavailable and there were no printers showing in System Preferences, nor would it let me add any new ones.

After panicking for a bit, and here's the hint (although it may be obvious), I reinstalled first gutenprint then cups 1.2.4, and everything was back to normal.
    •    
  • Currently 2.14 / 5
  You rated: 4 / 5 (7 votes cast)
 
[9,086 views]  

10.4: Fix a possible gutenprint issue under 10.4.8 | 2 comments | Create New Account
Click here to return to the '10.4: Fix a possible gutenprint issue under 10.4.8' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.4: Fix a possible gutenprint issue under 10.4.8
Authored by: mbroughtn on Oct 10, '06 06:00:50PM

This is not a Gutenprint issue. It is an issue with your installing CUPS v1.2.4 over the Apple supplied v1.1.23. The 10.4.8 update contained a new daemon file for CUPS (/usr/sbin/cupsd) which would not be compatible with CUPS v1.2.x. There are significant differences between CUPS v1.1.x and v 1.2.x. They are not interchangeable.





[ Reply to This | # ]
"server-error-service-unavailable" fix: reinstall CUPS 1.2.x AFTER 10.4.8 update
Authored by: mwc5 on Oct 16, '06 05:55:01PM

I have been tied in knots for days trying to figure out why my printing system blew up after Software Update got me to 10.4.8. Thanks to both of you for the solution.

BEFORE applying the 10.4.8 update from Apple, I had updated GIMP-Print 4.x to Gutenprint 5.0 (which replaced GIMP-Print) AND updated CUPS from 1.1.x to 1.2.x. THEN Software Update downloaded and applied the 10.4.8 update. Printing caused crashes. Uninstalling and reinstalling drivers led to VERY long "Searching for drivers" messages (spinning ball, etc.), which always resulted in the message "server-error-service-unavailable".

Once I found these comments, I reinstalled the latest stable version of CUPS (this time OVER the 10.4.8 update!) and everything is working again. I assume the CUPS reinstallation overwrote the incompatible new CUPS daemon (cupsd) included in the 10.4.8 update. Hope I remember this solution the next time Apple "updates" an obsolete version of CUPS or other common Unix program included in OSX.

THANKS to both of you for the fix!

---
PowerMac G5
OSX 10.4.8



[ Reply to This | # ]