Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Another site upgrade report... Site News
This problem has been resolved. We may have to do a bit of cleanup on new comments, but everything else should be fine.

We've noticed an issue with "special" characters in stories, comments, and usernames imported from the old database. This is primarily an issue in words with accented e's, e.g. Exposť, as you can see in the title to this hint ... but it will happen to any accented character we had in the system at the time of the upgrade.

For users with accented characters in their username, this means they cannot login at the moment. We're working on the problem, and will probably have to go offline for a bit later today to resolve it. I apologize for the troubles; the export and import routine worked perfectly in testing, but something snuck in (of course) when we did the live update.

On the (minor) good news front, I have fixed the comment layout so that lines are no longer hard wrapped...

-rob.
    •    
  • Currently 1.29 / 5
  You rated: 1 / 5 (7 votes cast)
 
[3,844 views]  

Another site upgrade report... | 13 comments | Create New Account
Click here to return to the 'Another site upgrade report...' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
The encoding seems fine
Authored by: chtito on May 31, '06 08:31:41AM

Actually the encoding seems to be perfectly ok. The problem is only in the http header: you now have to serve your pages in utf-8 instead of iso-8859-1. In php that would be something like: header('Content-Type: text/html; charset=iso-utf-8').



[ Reply to This | # ]
The encoding seems fine
Authored by: chtito on May 31, '06 08:33:48AM
in the previous comment read: header('Content-Type: text/html; charset=utf-8'); of course.

[ Reply to This | # ]
The encoding seems fine
Authored by: robg on May 31, '06 12:12:57PM

That's exactly what it was. It seems somewhere along the line, something switched.

So now I just have a minor cleanup job on some new comments -- thanks!

-rob.



[ Reply to This | # ]
Still problems...
Authored by: aamann on Jun 01, '06 09:57:28AM

Rob,

there still seem to be problems - all apostrophes show up as \' instead as ' only

(for and example, see comments to 10.4: Fix WebDAV under Apache2)



[ Reply to This | # ]
Still problems...
Authored by: robg on Jun 01, '06 09:59:09AM

The comments have issues that I'm trying to figure out -- the data file is identical in both versions of Geeklog, but the slashes show in the new version, not in the old version.

The slashes in the titles in the RSS feed, I'm not sure what to do about that. I've asked the plug-in author to take a look...

-rob.



[ Reply to This | # ]
Still problems...
Authored by: robg on Jun 05, '06 05:30:36AM

OK, the "backslash in older comments before single quotes" problem has now (finally, I hope!) been resolved.

-rob.



[ Reply to This | # ]
Another site upgrade report...
Authored by: osxpounder on May 31, '06 03:19:35PM

Where's the place I can click to see my most recent posts, so I can follow up on questions I asked or answered in the comments?

Did you move it, or is it ... gone? [I'd be sorry if it were gone.]

---
--
osxpounder



[ Reply to This | # ]
Another site upgrade report...
Authored by: robg on May 31, '06 03:54:25PM

Click your username in any post :). I need to add a link back to the user's profile page, I think I had it there before.

-rob.



[ Reply to This | # ]
Another site upgrade report...
Authored by: osxpounder on Jun 02, '06 03:00:52PM

Thanks, that'd be helpful. If possible, it'd be great to have a link that says "See your recent activity" or something similar, and yet to also have a link where our username appears after we log in.

Where it says "Welcome to macosxhints.com, osxpounder" ... that'd be a good place to link to this, or just to link the username to the Account Prefs.

BTW, I stumbled on another way to find it before I saw your post. I almost submitted my way as a hint! My way is easier to find, but takes longer. Instead of finding an old post [which is hard to do until this feature is restored, right?], I went to Account Preferences, clicked the Save Information button, and was taken to the page we're talking about -- the one listing my recent posts.

What the heck, I'll go ahead and submit it.

---
--
What clown decided that the iPod calendar view didn't need to show you the Location field? I guess they always use the same room at Apple.



[ Reply to This | # ]
Another site upgrade report...
Authored by: robg on Jun 02, '06 04:26:24PM

OK, that's done -- your profile is now linked to your name in the header bar. Getting it on the profile page is, annoyingly, actually much tougher (the variable I need to use isn't available on those templates).

In the old site, I hacked the source code to send that info to the template, but I'm trying to avoid too much customization in the new one. So the header will have to do, I think -- I'll add a text message to the profile page, though, explaining how to see your post history.

-rob.



[ Reply to This | # ]
Another site upgrade report...
Authored by: The_Decryptor on May 31, '06 10:10:17PM

It looks like the encoding might be broken in the RSS feeds (or it's just my end)

the ť in Exposť shows as √ɬ© (so Expos√ɬ©)



[ Reply to This | # ]
Another site upgrade report...
Authored by: ework on May 31, '06 11:00:41PM

Same here



[ Reply to This | # ]
Another site upgrade report...
Authored by: robg on Jun 01, '06 04:07:42AM

Fixed. RSS feeds character sets are, it seems, set in yet another spot. I'll figure this out eventually :).

-rob.



[ Reply to This | # ]