Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: Use iSync with a Nokia 6230 with older firmware System 10.4
Tiger only hintIn Apple's latest update (10.4.6), they have finally added iSync support for Series 40 Nokias, including the 6230. Unfortunately for some reason, that only applies to 6230's with later firmware revisions.

However, there does seem to be a workaround. I found the following in this Apple Discussions thread, so all credit to Aur for posting there. But in the interest of easy searching, here is the process -- back up first, of course!
  1. Go into /Applications, control-click on iSync.app, and choose Show Package contents from the pop-up menu.
  2. In the new window that opens, navigate into Contents -> PlugIns -> ApplePhoneConduit.syncdevice -> Contents -> PlugIns -> PhoneFamilies.phoneplugin -> Contents -> Resources
  3. Open the MetaClasses.plist file with TextEdit.
  4. Search for isPhoneSupported. Not far below that point, you should see return 0; change that to return 1. If you need more context, here's the whole block.
  5. Save, quit TextEdit, and relaunch iSync.
I can confirm that this works (so far), but obviously, there might be a good reason Apple decided against allowing 6230s with older firmware to sync, so use at your own risk.
    •    
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[33,075 views]  

10.4: Use iSync with a Nokia 6230 with older firmware | 9 comments | Create New Account
Click here to return to the '10.4: Use iSync with a Nokia 6230 with older firmware' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.4: Use iSync with a Nokia 6230 with older firmware
Authored by: Forcer on Apr 14, '06 01:09:16PM

Great hint for us 6230-people!

Thanks for posting it here, would never have found it otherwise :)



[ Reply to This | # ]
10.4: Use iSync with a Nokia 6230 with older firmware
Authored by: olsen on Apr 19, '06 04:56:21AM

The stated text block does not exist in my plist file... searching for "isPhoneSupported" ends with 0 results.

---
Mac Gamer



[ Reply to This | # ]
10.4: Use iSync with a Nokia 6230 with older firmware
Authored by: andrep on Apr 19, '06 06:43:56PM

My MetaClasses.plist contains two instances of the isPhoneSupported() function (lines 1160 and 1479 in the .plist file). After editing the first, iSync still refused to play.

It was only after I found the second instance and changed this too, that I could sync the phone.



[ Reply to This | # ]
10.4: Use iSync with a Nokia 6230 with older firmware
Authored by: wantmore on May 02, '06 12:13:52AM

Hello
I changed both instances of the return value
but can't get it to work. My firmware is 3.14.
Any suggestions?
If I upgrade to 5.50, will it work and how much should I be willing to pay :-( ?
Tnx



[ Reply to This | # ]
How can you check the firmware version?
Authored by: makip on Apr 19, '06 09:35:21PM

Does anyone know how to check the firmware version on a 6230 / 6230i ?

It would be useful to know this prior to selecting a refurbished 6230i handset (which is our company's current standard issue handset).

thanks, Maki



[ Reply to This | # ]
How can you check the firmware version?
Authored by: andrep on Apr 20, '06 07:10:48AM

*#0000#

- gives you the firmware version in the first line



[ Reply to This | # ]
How can you check the firmware version?
Authored by: fierceb on Apr 26, '06 08:16:30PM

you can do it by the following:

*#0000#

The solution provided in this article does work on mine which has a firmware of 4.43. So I did not need to upgrade it. I hear the latest version of firmware 5.3 (i think) solves it automatically without need of using the solution provided on this topic. Hope that helps. BTW Once you get it working you will be amazed how easy your life has gotten :)



[ Reply to This | # ]
How can you check the firmware version?
Authored by: makip on Apr 29, '06 08:57:34PM

Thanks for the responces.
A note to say the 6230i has different version numbering to the 6230. My 6230i has firmware v03.70 and it syncronises well.



[ Reply to This | # ]
10.4: Use iSync with a Nokia 6230 with older firmware
Authored by: afterhours on Sep 03, '07 06:56:44AM

late follow up here, but my Nokia 6230 syncs well with 10.4.10 with no plist adjustments. I also use PhoneDirector. Each has their strong points (I wish PhoneDirector had used iCal and AddressBook for their implementation of those features -- AddressBook works a lot better with the 6230 firmware than the built-in address book in PhoneDirector, but PhoneDirector gets to far more features in the phone than iSync was intended for... easily as useful as the PC Suite Nokia won't port over to the Mac.

Now, if someone can come up with a source for firmware updates for the 6230, I'll be all set. Nokia's PC Suite doesn't support firmware updates for the 6230, and questions to them have yet to be answers. Heck, from their website, it would appear there may only be one qualified service center in the States for firmware updates -- NYC. I'm not driving there to get the firmware updated, and I'd rather not mail my cell phone somewhere...



[ Reply to This | # ]