Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Install Java 1.5 onto 10.3 Panther Install
Download the J2SE 5.0 for Tiger file from the Apple website. Drag the resulting .pkg file onto the Desktop, control-click on it, and choose Show Package Contents from the pop-up menu. Navigate into Contents and trash the InstallationCheck file. Finally, run the pkg file, and there ya go!

Now you can put the new Java onto 10.3, even though Apple says you can only put it on 10.4.

[robg adds: I have not tested this one, and I have no idea if there are any dependencies in 10.4 that would prevent the new Java from working properly (even though it's installed) under 10.3. If you know more, please feel free to comment...]
    •    
  • Currently 1.71 / 5
  You rated: 5 / 5 (7 votes cast)
 
[35,631 views]  

Install Java 1.5 onto 10.3 Panther | 5 comments | Create New Account
Click here to return to the 'Install Java 1.5 onto 10.3 Panther' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
This Will Not Work
Authored by: adriansutton on Nov 23, '05 01:24:30PM

Don't do this, it simply will not work. While some of the command-line functionality of Java can run on earlier systems the GUI code most definitely depends on new features added in 10.4.

This "hint" has been floating around for a long, long time and has been shown to not work many, many times. Don't waste your time. If you want to keep track of Java on OS X, I suggest searching through the Java-Dev archives at http://lists.apple.com/archives/



[ Reply to This | # ]
This Will Not Work
Authored by: billbarstad on Nov 25, '05 06:40:35AM

Thanks. I was waiting to see what the response to this hint would be before truing it. I'm glad I did.



[ Reply to This | # ]
Install Java 1.5 onto 10.3 Panther
Authored by: Ilgaz on Nov 25, '05 10:57:43AM

We should be happy that Dell trolls are really stupid. :) They are still in 1 button mouse times...

What I mean is:

JRE 1.5

Platform(s):
Windows 98, Windows ME, Windows 2000 (SP4+), Windows XP (SP1 SP2), Windows 2003

So, if one wants JRE 1.5, he/she must buy "Tiger".

Apple keeps doing it...



[ Reply to This | # ]
Install Java 1.5 onto 10.3 Panther
Authored by: jdb8167 on Nov 27, '05 05:55:00PM

I'm not sure exactly what you are saying but if you are commenting that Windows back to Windows 98 works with Java 1.5 and on OS X it requires Tiger then you should be aware that Sun is the one maintaining the Windows Java platform. Microsoft has nothing to do with it. Apple on the other hand is porting Java from Sun to OS X.

So, this has to do with differing priorities of the two companies. Apple needs a decent Java platform but the reality is that unless you are willing to upgrade to the latest OS, Apple isn't likely to spend money on you for a minority language/platform. If you are an enterprise customer or someone who needs the latest and greatest version of Java, asking to support Apple's development efforts by buying the latest OS isn't too much to ask in my opinion. It isn't like Java 1.4 is obsolete it just isn't the absolute latest. For the vast majority of Java users on OS X, Java 1.4 is the more compatible solution anyway.



[ Reply to This | # ]
Java on Mac is better than Java on Windows
Authored by: hayne on Nov 28, '05 01:26:46PM

As I understand it, the main reason why Java 1.5 (aka Java 5.0) is only supported on Tiger is that the GUI part of Java (Swing) makes use of some Cocoa features that are only available on Tiger.
Apple has put a lot of work into making Java apps look and feel like regular Aqua apps. And Java apps on Mac look better and work better than Java apps on Windows (judging mostly from the medium-large desktop app that I have written).
So that is part of the reason why Java 1.5 might only be available for Tiger whereas it is available for older versions of Windows - it wasn't necessary to do as much work to get it working on Windows, possibly because of a lower standard for acceptance.



[ Reply to This | # ]