Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: iPhoto 5.0.x and unwanted color shifting Apps
Tiger only hintSeveral people have reported problems with iPhoto 5 making unwanted changes to pictures. Some have observed that there is some kind of Colorsync profile issue involved with encoding in pictures. Following that lead, I tried something. I'm somewhat color blind and most normal screens look bluish to me -- so I've taken to making my screens customized balanced to my eyes which others report as somewhat reddened.

I have had a strong form of the iPhoto 5 problem. So I tried resetting the color balance in the Display preferences back to defaults, and suddenly iPhoto 5 doesn't severely alter the color balance (or nearly as much). It still alters the picture when clicking Done, but the effect is far reduced and perhaps even good sometimes. However, if you change sharpness on a picture, that change is still lost.

Many of the general issues have been covered on a MacFixit thread, but I've seen no one offer any workaround. I agree it is a bug that Apple needs to fix, but this has left me in a workable, if not what I'm used to, using iPhoto to edit pictures.

[robg adds: I hadn't heard of this problem before, so I followed a test suggestion in the above-linked thread, with a slight change. I duplicated an image, then did four "Retouch" operations on the duplicate, saving after each retouch. I only clicked on one pixel with the Retouch brush (i.e. no dragging), so this should have only affected four pixels in my modified image (at least, that's how I understand Retouch from the help page). As you can see below, the modified image on the left has been dramatically lightened:


The histogram for each image is revealing, too. The wash out is plainly obvious when you compare the before and after histograms; there has been a pronounced shift to the right in the histogram.

I tried the fix suggested in this hint, but didn't notice any difference in how iPhoto modifies the images -- they were still getting unacceptably lightened whenever I edited them. So I then told iPhoto to use an external editor (Photoshop Elements 3) and repeated the experiment -- I used the blur tool to blur four very small areas of the image. As expected, the before and after images were basically identical, and the histograms were changed by only a pixel here and there.

Needless to say, I've now set iPhoto to use Elements as its editor, at least until Apple fixes this bug. I've also reverted all the edits I've done using iPhoto (select any number of images, then choose Photos -> Revert to Original), and I'll go back and use Elements to fix red eye, etc. in a whole bunch of images. According to something else I read, this problem only affects iPhoto5 in Tiger, not in Panther. Hence, I've marked this hint "Tiger only."]
    •    
  • Currently 2.50 / 5
  You rated: 2 / 5 (4 votes cast)
 
[15,186 views]  

10.4: iPhoto 5.0.x and unwanted color shifting | 8 comments | Create New Account
Click here to return to the '10.4: iPhoto 5.0.x and unwanted color shifting' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.4: iPhoto 5.0.x and unwanted color shifting
Authored by: mclbruce on Jun 20, '05 11:45:15AM

I have seen this problem with iPhoto 5 in Panther.

The best explanation I have seen for the problem is here:

http://www.macintouch.com/iphoto13.html#jun14

As far as the hint goes, it seems like changing the display profile to one that's similar to Generic RGB will reduce or eliminate the problem. However it may make your display look bad.



[ Reply to This | # ]
10.4: iPhoto 5.0.x and unwanted color shifting
Authored by: tjreo on Jun 20, '05 12:24:19PM

I agree with reverting to the original and using Elements to fix the images. However, I have a few hundred images to fix and I have not found a way to tell iPhoto to use Elements (the external editor) to batch Auto-Fix a bunch of pictures. This one missing feature is driving my wife (and me) nuts.

Does anyone have suggestions as to how to do this?

If I select multiple images from iPhoto and control-click the images and choose "edit in external editor", only half show up in the Elements photo bin. Then I have to auto-fix them one at a time. The batch update modes don't let me save the updated images back to iPhoto. Hopefully, I am missing something obvious.

Any clues?



[ Reply to This | # ]
re: iPhoto 5.0.x and batch editing in P/E
Authored by: mclbruce on Jun 20, '05 02:58:00PM

Try dragging the selected items in iPhoto to the P/E icon in the dock.



[ Reply to This | # ]
10.4: iPhoto 5.0.x and unwanted color shifting
Authored by: mattharris5 on Jun 20, '05 02:18:20PM

According to thinksecret.org, this bug should be fixed in the 10.4.2 update: "The latest builds reportedly correct such annoying bugs as iPhoto lightening an image after saving an edited version of the image..."



[ Reply to This | # ]
10.4: iPhoto 5.0.x and unwanted color shifting
Authored by: Panjandrum on Jun 20, '05 07:15:08PM

I've had the same problem with iPhoto 5. When I hit the "done" button any photo I've edited washed out horribly. This has rendered iPhoto 5 useless to me. I haven't tried to resolve the issue because for my purposes I've found every version of iPhoto to have some issue which makes the program functionally useless to me. Most annoying is that Apple insists on creating a program which organizes the files itself, rather than simply using the folder structure I desire. Until they fix that horrible "feature" iPhoto will remain little more than a program I install, run, find out I still can't use for anything, and then delete.

---
==============================
David Butler
http://www.macmaven.net/
http://www.dhbutlerphotography.com/



[ Reply to This | # ]
10.4: iPhoto 5.0.x and unwanted color shifting
Authored by: adams4 on Jun 21, '05 12:51:45PM

From what I've heard, the color-shift problem is going to be fixed in the 10.4.2 update, which is due out any minute now....

---
Adam Spector.



[ Reply to This | # ]
10.4: 10.4.2 did not fix that :-(
Authored by: gerti on Jul 12, '05 08:14:34PM

Subject says all, I just updated to 10.4.2 and it still washes out photos after pressing the 'Done' button... &*()&&%_!



[ Reply to This | # ]
10.4: 10.4.2 did not fix that :-(
Authored by: robg on Jul 14, '05 09:12:07AM

You need to also get iPhoto 5.0.3, released late last night.

-rob.



[ Reply to This | # ]