Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Use Java 1.5 on 10.3 System
I am desperately waiting for Java 1.5. But I dont want to switch to Tiger. So I downloaded the new Java 1.5 from Apple's Developer Site. Unfortunately, the installer wouldn't proceed, because my current OS version is below 10.4. Then I used Pacifist, the package installation utility. Pacifist installed it just fine.

After changing the link of the CurrentJDK to 1.5...
/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK -> 1.5
... I can use java 1.5 on 10.3:
$ java -version
HotSpot not at correct virtual address. Sharing disabled.
java version "1.5.0_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)
Java HotSpot(TM) Client VM (build 1.5.0_02-36, mixed mode)
So far, I haven't had any problems, but I'll investigate it further.
    •    
  • Currently 3.67 / 5
  You rated: 5 / 5 (6 votes cast)
 
[21,883 views]  

Use Java 1.5 on 10.3 | 12 comments | Create New Account
Click here to return to the 'Use Java 1.5 on 10.3' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Use Java 1.5 on 10.3
Authored by: deleted_user18 on May 05, '05 01:55:19PM

You don't have "sharing" which you have when installing Java 1.5 on Tiger. But I have no clue what sharing means here :-)



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: adrianm on May 05, '05 02:00:40PM

Java since 1.4.2 from Apple and since 1.5 from Sun has had the ability to share constant memory footprint (default classes, including hotspot compiled code) amongst multiple java instances.

It's harmless to see this error but memory and startup performance will suffer (down to pre 1.5 windoze levels!)

Note that Apple's 10.3.9 update managed to screw around with this too, so maybe that's it.



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: dille on May 05, '05 02:28:38PM
Hm, after changing the CurrentJDK link, jEdit refuses to run. Moving back the old link fixes it, so it really is a problem with the new JDK. A snippet from my console.log:

dyld: /Applications/jEdit 4.2/jEdit.app/Contents/MacOS/JavaApplicationStub Undefined symbols:
/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libawt.jnilib undefined reference to _kCTForegroundColorFromContextAttributeName expected to be defined in ApplicationServices
/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libawt.jnilib undefined reference to _NSAccessibilityTopLevelUIElementAttribute expected to be defined in Cocoa
/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libawt.jnilib undefined reference to _NSAccessibilityInsertionPointLineNumberAttribute expected to be defined in Cocoa
Any idea as to how I can solve this? Should I try installing again? (Pacifist asked me whether to treat /System/Library/CoreServices/Jar Launcher.app as an update or a new install -- tried both, doesn't change a bit).

[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: Bozo77 on May 05, '05 02:51:25PM

Buy Tiger if you want Java 5 because this hint just won't work, simple as that.



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: jzdziarski on May 05, '05 05:57:08PM

I'm running Tiger and Java 1.5, and get similar JNI errors. I think it's because the JNI libs were compield for 1.4. I don't see any 1.5 versions of it...so I can't run some apps I compile :(



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: dille on May 05, '05 06:06:13PM

Could you (or someone else with Tiger) do me a big favour and check to see if jEdit runs on your 10.5 install? It's a free download from jedit.org.



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: itistoday on May 05, '05 07:36:35PM

yes yes, jEdit runs on 10.4 with java 1.5. However, it slows down a LOT. In fact, sometimes things get so slow that the CPU skyrockets just from scrolling or selecting text.



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: dille on May 06, '05 09:22:31AM

And how are things under the "regular" Java? 1.4.2, right?

(Yes, I know, I'm asking way to many questions =] )



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: itistoday on May 07, '05 11:14:40AM

If I remember correctly, by not installing Java 1.5 everything should work correctly. (Plus Acqusition breaks if you install java 1.5, even if you try to set the version back to 1.4.2).



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: Bozo77 on May 05, '05 02:49:36PM

CAUTION!!! This hint is evil!

It will leave you with a _completely_ unsupported system and Java 1.5 will not work as expected. For this version of Java, Apple uses new Cocoa features that were introduced with Tiger, so it is highly likely that Swing / AWT will be broken, i.e. some apps will not run, others might exhibit unexpected behavior.

Java on Tiger uses graphics acceleration that was previously not present on OS X. Just because some people think Apple has deliberately disabled installation on Panther, this does not change the facts - Panther does not have the proper support that is needed for this version. Believe it or not, but there is a reason that it does not install on Panther. Do as you please, but you have been warned.



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: nmerriam on May 06, '05 12:27:39AM

Java 1.5 barely works with anything in Tiger -- I can't imagine how crippled it would be in Panther!

Seriously, if you don't NEED Java 1.5 for something, don't bother with it, regardless of which system you're using. It seems to completely break 4 or 5 apps for every one it helps.



[ Reply to This | # ]
Use Java 1.5 on 10.3
Authored by: jasenko on May 10, '05 07:41:03PM

I also had to change the links to make Java 1.5 work in Tiger. Note that you have to change both links (Current and CurrentJDK) for stuff to work.
At the moment, everything is running smoothly, all applications that require 1.5 are happy. Here are the instructions for those who need them:

cd /System/Library/Frameworks/JavaVM.framework/Versions

sudo mv Current Current.old
sudo ln -s 1.5 Current

sudo mv CurrentJDK CurrentJDK.old
sudo ln -s 1.5 CurrentJDK

I can't see that this should not work in Panther, but maybe some pointers to some libraries are changed and that is the reason. It's easy to go back if you want to anyway.



[ Reply to This | # ]