Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Workaround a grouped object linking bug in Keynote2 Apps
While working on a presentation last night, I noticed a problem: I had created an object by grouping a few others together, and I then made that object a hyperlink. Everything worked fine in testing, so I saved my changes, went to sleep, and then got up this morning to work on it some more. When I opened the slides, though, my hyperlink was gone. The grouped object was still grouped, it just didn't have the hyperlink shortcut arrow on it, and (obviously) didn't work as a hyperlink.

A quick read-through in the Keynote topic on Apple's Discussions forums found the answer, posted in this thread by 'Johnny Turner.'

Basically, you have to hyperlink one of the individual objects first, and then you can group the objects together into the final object. After saving, closing, and re-opening, the hyperlinks remain intact. I tested this with grouped items consisting of all text, all objects, and a mix of both, and it seems to hold true for all of them. As long as you make the link first, then group, the links will be retained after closing and re-opening the presentation.
    •    
  • Currently 1.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[3,866 views]  

Workaround a grouped object linking bug in Keynote2 | 3 comments | Create New Account
Click here to return to the 'Workaround a grouped object linking bug in Keynote2' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Workaround a grouped object linking bug in Keynote2
Authored by: azxplorer on Jan 28, '05 09:34:24AM

Wow,

Thanks for posting this. Its not often that we get to see our own name posted on a prominent web site.

Johnny Turner (azxplorer)



[ Reply to This | # ]
Workaround a grouped object linking bug in Keynote2
Authored by: robg on Jan 28, '05 12:26:13PM

Thank *you* for finding the fix! It was driving me crazy; I thought I'd forgotten to save my work or something!

-rob.



[ Reply to This | # ]
Workaround a grouped object linking bug in Keynote2
Authored by: ajweiss on Jan 28, '05 08:30:50PM

I spent two hours on the phone with apple on Wednesday night trying to fix this, and they had no idea what to do about it. I've been in correspondence with a high-level support specialist at Apple about it, and I'll be sending him a link to this solution. Even the engineers who write the program couldn't figure it out. Way to go!



[ Reply to This | # ]