Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

A complete solution to using AfterDark screensavers System
Some time ago, a hint of mine was published about using some old After Dark screen savers as screen savers under OS X. The hint wasn't completely reliable, but now I've found a way to make it work perfectly. Start out by creating an AppleScript that launches the MacDim AD Launcher, as described in the original hint. Next, dowload and install Platypus, and use it to create a Cocoa application wrapper around the AppleScript.

Next, download and intall AppStartSaver, a screen saver that launches OS X applications, but in its current version doesn't natively launch AppleScripts or Classic apps. Select the Cocoa wrapper that you created with Platypus, and use it as the application that the saver launches.

The result is an OS X screen saver that smoothly launches After Dark savers. Presumably this method will work with other OS 8/9 screen savers.
    •    
  • Currently 2.75 / 5
  You rated: 4 / 5 (4 votes cast)
 
[12,073 views]  

A complete solution to using AfterDark screensavers | 6 comments | Create New Account
Click here to return to the 'A complete solution to using AfterDark screensavers' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
A complete solution to using AfterDark screensavers
Authored by: adrianm on Jan 03, '05 11:30:10AM

Cool, but do you need to the Platypus step? Surely saving the AppleScript as an 'Application Bundle' makes it a GUI-clickable application bundle?



[ Reply to This | # ]
A complete solution to using AfterDark screensavers
Authored by: koncept on Jan 03, '05 11:06:26PM

Bundles work for Panther > AFAIK..



[ Reply to This | # ]
Does this allow scrolling messages?
Authored by: tcurtin on Jan 03, '05 12:55:03PM

One of my favorite features with Afterdark was that when the OS put up an alert box, the alert text would scroll across the bottom of the screen while the saver was still running.

Does this hint allow this functionality?

If not, does anyone know of a way to do this?

I'd love to be able to tell at a glance again when I've got mail or a download has finished...

---
"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety."
- Benjamin Franklin



[ Reply to This | # ]
A complete solution to using AfterDark screensavers
Authored by: emendelson on Jan 04, '05 07:09:51AM

About the Platypus bundle: different versions of this AppStartSaver work in different ways. The version I tested did not launch AppleScript applications (it popped up a message instead); maybe the current version does work with them, but I don't think so.

I know it's logical to assume that the Saver could launch AppleScripts and Classic apps, but it can't - although the developer says he's going to work on it for the future. Until it can launch AppleScripts and Classic apps, the Platypus bundle makes things work.



[ Reply to This | # ]
A complete solution to using AfterDark screensavers
Authored by: ottRider on Jan 06, '05 09:59:58AM

The latest version (1.5) will do these things. It can now run compiled Applescripts directly, so the Platypus step can be skipped.

(The problem was that the Applescript editor compiles scripts into Carbon applications, not OS X Native applications. so the Carbon/Classic support was necessary before this would work.)

As for whether AD's ability to intercept alerts & put them in banners will work, I don't know but I doubt it. (Maybe for classic applications.) OS X alerts are produced by a framework AD wouldn't know about.

Regards
Richard



[ Reply to This | # ]
A complete solution to using AfterDark screensavers
Authored by: gulmatan on Mar 26, '05 10:16:53PM

Well, I'm on a new PB-G4 OS/X (v10.3.8). My problem is that AfterDark 3.0 crashes my Classdic Startup so, I'm fiorced to use AfterDark 2.0v. How can I use version 3.0 so that i can select my Star Trek (TOS, TNG) screen saver modules?

The Star Trek Screen Posters modules work. How can I get mt AfterDark 3.0 modules to work?



[ Reply to This | # ]