Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.3: A fix for sent Mail messages not getting saved Apps
I've never seen mention of anyone else having this problem, but who knows... maybe there is someone out there.

After my clean-install of Panther and restoring my mailboxes from backup, I noticed that the sent mail from one of my email accounts was not getting saved. It's an IMAP account, and I tried all permutations of preference settings, deleting the .plist file, and deleting/re-adding the account -- all to no avail.

After some poking around in various log files, I noticed an error message indicating that the mailbox "Sent Mail (school email)" could not be created because it already existed. I then realized that my (possibly not-so-kosher) method of restoring my mail folders (coping all my old Jaguar .mbox files into ~/Library/Mail/Mailboxes/) had led to some problems. Instead of creating a folder for "school email" nested within the "Sent" folder, it created an entirely different "Sent Mail (school email)" folder which contained all my old sent messages for that account.

When I removed that mailbox folder, everything was restored to normal and sent messages are saved properly for all accounts. A "school email" folder was created nested under the "Sent" folder.

    •    
  • Currently 2.14 / 5
  You rated: 4 / 5 (7 votes cast)
 
[7,719 views]  

10.3: A fix for sent Mail messages not getting saved | 0 comments | Create New Account
Click here to return to the '10.3: A fix for sent Mail messages not getting saved' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.