Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.3: Update URIs for Samba printing to Windows System
I use OS X to print to a Windows domain. Once I installed Panther, all my CUPS printers stopped working (this was an upgrade install of Panther over Jaguar). Turns out the required format of the URI for the printer is slightly altered in Panther:

Jaguar: smb://username:password@domain/server/printername
Panther: smb://username:password@server.domain/printername

For some reason, those two URI's are not interchangeable. Please note I have this machine bound to the domain, which may or may not make a difference. Hope this helps!

    •    
  • Currently 1.00 / 5
  You rated: 1 / 5 (6 votes cast)
 
[17,047 views]  

10.3: Update URIs for Samba printing to Windows | 8 comments | Create New Account
Click here to return to the '10.3: Update URIs for Samba printing to Windows' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.3: Update URIs for Samba printing to Windows
Authored by: rskoss on Nov 16, '03 08:43:54AM

I still get NT_ACCESS errors. I used:

smb://solo.workgroup/hplj

where 'solo' is the machine name, 'workgroup' is the workgroup, and hplj is the name of the shared printer on the Win2000 box.

smb://solo/hplj doesn't work either.



[ Reply to This | # ]
10.3: Update URIs for Samba printing to Windows
Authored by: potel on Nov 19, '03 07:56:48PM

Where exactly are you enteringi the new smb: syntax? I have the same problem, I did an upgrade install of Panther over Jaguar and printing to my Windows shared printers stopped working. The main problem is that the new "Windows printing" under the Panther Printer Setup Utility finds my workgroup name but no printers show up, even though they were working under Jaguar and still work from my other machines. Under Jaguar, I set up smb: under the "Advanced" tab of Print Center, but now in Panther there's no more Print Center and I can't see where to do the comparable thing in the Printer Setup Utility. Can you help? Thanks!



[ Reply to This | # ]
10.3: Update URIs for Samba printing to Windows
Authored by: potel on Nov 20, '03 10:56:05PM

Todd replied to me offline, the answer is to open http://127.0.0.1:631 in your browser and go from there.



[ Reply to This | # ]
10.3: Update URIs for Samba printing to Windows
Authored by: mitra on Jul 26, '04 08:32:10AM

That cups browser interface requires a password - any idea what its using for the password - its not my user id.



[ Reply to This | # ]
10.3: Update URIs for Samba printing to Windows
Authored by: mitra on Jul 26, '04 08:35:01AM

That cups browser interface requires a password - any idea what its using for the password - its not my user id.



[ Reply to This | # ]
10.3: Update URIs for Samba printing to Windows
Authored by: apoc_metal on Jun 17, '05 01:24:33PM

Use "root" for login, and then either blank for the password (if you have no root password set?) or your admin password...
I tried logging in with my normal admin login/pass but that didn't work.

Also, not sure how the web interface is helpful, except that it allows me to work around the fact that my print utility doesn't see any shared windows printers (not even the workgroups show up)

Could this be a conflict from SharePoints?
If so, is there an easy way to uninstall it, so that the old settings are restored? I thought it had something to do with being in the same workgroup, since osx automatically puts me in "workgroup" while the pc's are in "MSHOME", but there is no easy way to change either setting (on mac or pc)

Also, a co-worker with a mac finds the printer and has no trouble printing. I'm on 10.3.9, i think she is using an earlier panther edition.
Hopefully this post isn't too old to be noticed... Maybe I'll repost it somewhere more recent....



[ Reply to This | # ]
10.3: Update URIs for Samba printing to Windows
Authored by: storwalle on Nov 28, '03 03:10:13AM

I have tried the tips but it resulted in the below:

Alt-clicking the Add Printer button doesn't result in anything else than the ordinary clicking on the Add Printer button. Choosing Windows Printer leaves me with no option to add a URI like the proposed.

Using IP-printing leaves me with the message saying "Inaccurate address reference" or similar. I can only put in the domain name there without the prefix "smb://" or "cifs://".

Trying to reach the Samba server through the browser on port 631 left me clueless. Couldn't reach the server, was the message...

Using IP printing with an accurate domain name and a printer qeue name leaves me with the Print Center stopping at "Trying to reach... at port 631". Could this be a firewall problem at the Samba server? But the Shorewall firewall is set up to ACCEPT TCP on port 631...

Someone that has any good hints?

Kind regards
Michael

---
Mr Michael says:



[ Reply to This | # ]
10.3: Successful printing to Windows!
Authored by: strikeman on Sep 21, '04 05:38:14AM

I had the problem where my Windows box couldn't be seen in the Windows Printing list.

After much research and trial and error, I finally managed to successfully print from OSX 10.3.5 to a windows shared printer:

1) Turn on Print Services for UNIX on the windows box (http://www.ifelix.co.uk/tech/3002.html?artnum=19652)
2) On the Mac, in Printer Setup, add a printer
3) Choose IP printing, and LPD/LPR
4) Type your windows server name in Printer Address:
5) Type your windows shared printeer name in Queue Name:
6) Choose the appropriate printer. If your printer is not Postscript enabled, use one of the GIMP print drivers. Go to gimp-print.sourceforget.net to lookup which driver is appropriate.

This worked for me, but really should have been a *lot* easier.

NT Cheung
Hong Kong



[ Reply to This | # ]