Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

A possible fix for random application issues System
I was hit by a strange system bug that affected two very different circumstances... At least, they appeared dis-similar while attempting to troubleshoot. I was having an issue where Mindvision based installers would simply quit. Poof. Either immediately, or after a successful athentication if admin privs were required.

A brand new install of the OS worked to fix this, but only for new accounts, not for existing users that were migrated over. (Loooove that self-contained user folder... 'cept it self contains bugs too...).

As well, Bizzarre issues with Acrobat reader were abouding...And this is the weird part. The Acrobat reader installed by the system install would work fine (v5.0.0). The updated Reader (5.0.5) would die if launched as a carbon app, but not as a classic app. Also, an updated install of the Acrobat (editor) app would quit. The only note was a cryptic reference to the "Rulebook Server" in the console.

It turns out the fix was the same fix for all of these issues. As noted on the mindvision website in a kbase article, Installer VISE installers may have difficulty detecting the operating system language on some Mac OS X machines, causing the installer to unexpectedly quit. A workaround is to have the user make a small change in 'International' System Preferences.

That's it. ANY change, and the system will write out a new preference, and all will be happy. I've lost about 18 man-hours trying to troubleshoot this.
    •    
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[2,386 views]  

A possible fix for random application issues | 1 comments | Create New Account
Click here to return to the 'A possible fix for random application issues' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Well well well.
Authored by: james_sorenson on Feb 05, '02 06:07:01PM

Excellent find. Glad I didn't have to spend 18 hours to nail this glitch. Thanks!



[ Reply to This | # ]