Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Recover from a crashing Mail.app Apps
Yesterday, after the Aqua window server unexpectedly quit (due to some combinaton of Classihack, XDarwin 1.0.4.1, xchat, and the GIMP, I think) -- which drops you instantly back to the login screen (ouch!) -- I couldn't get Mail.app to run anymore. I'd start it up, the window would start displaying, and then it would quit. I've been using Mail for over a year, and this was the first real problem I'd had with it.

I tried all the 'usual' stuff. Trashed the prefs. Emptied my POP email via another program. Moved all my mailboxes out of the path. Booted in OS 9 and ran Disk First Aid. Booted single user and ran 'fsck -y'. Even copied a Mail.app from a known working system. Nothing worked. So I went looking for help, and found this thread on the MacFixIt forums. Turns out that three of us had the exact same problem yesterday!

On someone's suggestion, I tried logging in as another user, and was quite surprised to find that Mail.app ran perfectly. About the same time, I received a response from the X4U mailing list with the solution to the problem. Somehow, my ~/Library/Addresses folder had been damaged (probably by the Aqua crash). By moving this folder out to the desktop, I was able to run Mail as my normal user again. All three of us in the forum stumbled onto the solution at about the same time last night :-).

Now the only remaining question is if there's any way to recover some of the address book information. Probably not, but I'm going to investigate a bit more today.

-rob.
    •    
  • Currently 5.00 / 5
  You rated: 5 / 5 (2 votes cast)
 
[3,998 views]  

Recover from a crashing Mail.app | 1 comments | Create New Account
Click here to return to the 'Recover from a crashing Mail.app' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Recover from a crashing Mail.app
Authored by: avarame on Dec 17, '04 01:05:42AM

Got the same problem... in Panther. Unfortunately I don't seem to *have* a ~/Library/Addresses directory. Will try messing with Address Book all the same...



[ Reply to This | # ]